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Copyright 
 
KnowItAll Software Training Guide  
Copyright © 2020 by John Wiley & Sons, Inc.  
All rights reserved. 
 
 

Trademarks  
 
KnowItAll and ChemWindow are registered trademarks of John Wiley & Sons, Inc. in certain jurisdictions. 3DViewIt, AnalyzeIt, AssignIt, BrowseIt, 
GoodLook, KnowItAll ID Expert, IntelliBucket, KnowItAll AnyWare, MineIt, PredictIt, ProcessIt, QC Expert, ReportIt, Sadtler, SearchIt, 
SpectraBase, and SymApps, are trademarks of John Wiley & Sons, Inc. Pirouette is a registered trademark of Infometrix, Inc. 

 
 

Disclaimer    
 
John Wiley & Sons, Inc. makes no representations or warranties with respect to the contents of this publication or the accompanying software or databases. John 
Wiley & Sons, Inc. specifically disclaims any implied warranties of merchantability or fitness for any particular purpose. 

John Wiley & Sons, Inc. reserves the right to change or alter this publication and the accompanying software and databases at any time, without obligation to notify 
any persons of such revisions or changes. 

No part of this publication or the accompanying software and databases may be reproduced, transmitted, transcribed, stored for electronic or digital retrieval, 
translated, or copied by any mechanical, electronic, magnetic, optical, or manual means without expressed prior written consent of John Wiley & Sons, Inc. 
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About this Training Guide   
 

This training guide lead you through a series of exercises in the manner of a training course. Each lesson has a folder of example training files 
associated with it that can be downloaded here: www.knowitall.com/training_files 
 

Lesson Description Application Featured 

    General Features  Explore the interface  
 Learn to transfer data from one application to another 

KnowItAll "Interface" 

    1 - Simple Spectral Search / Identification  Perform a "first pass" analysis of your spectrum against reference spectra 
 Use patented optimized corrections technology to optimize search results 

KnowItAll ID Expert 

    2 - Searching 

 Perform a basic, peak, structure, and multi-technique searches 
 Create a search profile 
 Limit search range / exclude search regions 
 Perform a spectral subtraction 
 "All" vs. "Pure Compound" search 

SearchIt 

    3 - Mixture Analysis  Perform mixture analysis 
 Interpret search results 

SearchIt 

    4 - Create Databases 
 Create a database with spectra, structures, properties 
 Batch import spectra, structures, properties, PubChem properties 
 Create display profiles 

MineIt/Create Databases 

    5 - Functional Group Analysis 

 Browse the knowledgebase of functional groups 
 Correlate peaks from a structure 
 Perform spectral analysis by functional group – IR, Raman. IR Polymers 
 Create User Knowledgebases 

AnalyzeIt (IR, IR Polymer, 
Raman) 

    6 - Drawing Structures & Reactions  Use basic ChemWindow tools to create and edit a structure 
 Create chemical reactions 

ChemWindow, ReportIt 

    7 - Creating Reports  Use pre-defined report template 
 Create customized templates 

ReportIt 

    8 - Data Mining & Analysis  Use patented Overlap Density Heatmaps for visual data mining 
 Create an overlap consensus spectrum 

MineIt 

    9 - Quality Control Analysis  Set up administrator account 
 Select a standard and compare sample 

QC Expert 
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Training Files Used in This Lesson 
 Cholesterol.dsf 

KnowItAll Applications Used 
 BrowseIt™ 
 ChemWindow® 
 SearchIt™ 
 ReportIt™ 

 

General Features   
Introduction to the Basic Applications in the KnowItAll Informatics System 

 
Purpose 
 
This exercise demonstrates the features of the KnowItAll environment.  
 

Objectives 
 
This exercise will teach you: 

 How to open individual KnowItAll applications; 
 How to access on-line help; 
 How to transfer information from one application to another. 

 

Background 
 
All KnowItAll solutions are designed using a unique architecture that allows the seamless transfer 
of information from one software tool to another without having to leave the main interface.  
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The KnowItAll environment 

 Action Result 

1 Open the KnowItAll Informatics 
System by double-clicking its icon on 
the desktop. 

The KnowItAll Informatics System automatically opens to the BrowseIt application. This application offers access 
to a web community designed especially for KnowItAll users and access to training movies and other information. 

Notice the KnowItAll interface integrates a series of software applications within logically grouped toolboxes, so the 
user can move from one task to the next and transfer information from one application to another. 

As you move throughout the KnowItAll Informatics System, notice that certain screen elements are shared by all 
applications (e.g., Title and Menu bars; Back / Forward buttons; Transfer/Return to bar; and Application 
Toolboxes.) 

2 Explore the online Help. Open the Help menu and choose KnowItAll Help and Training.  This leads user to the online Help site. 

3 Examine the contents of the File, 
License, and Help menus. 

All KnowItAll Informatics System applications share the same Menu bar, located beneath the Title bar at the top of 
the application's window. The contents of the Menu bar change to reflect the current application as you move 
throughout the KnowItAll Informatics System. All applications include File, License, and Help menus. Other menus 
become available depending on the capabilities of each application.  
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The KnowItAll environment (continued) 

 6 Result 

4 Click each toolbox title in the 
Application Toolbox area on the left 
edge of the application window. 

Depending on the edition(s) you have, this area can have Basics, Data, Spectral Processing and Spectral 
Analysis. Click a toolbox title to open it.  
Click icons within the toolboxes to open and explore different KnowItAll applications. 

5 Navigate to the Basics toolbox, then 
open the ChemWindow application by 
clicking its icon. 

The application opens to a blank drawing pane.  

6  Choose File > Open 

 Navigate to KnowItAll > Training 
Files > General Training > Files > 
General Features  

 Open Cholesterol.dsf. 

Note: The Files of type filter on the 
Open dialog box allows you to specify 
which file types are displayed.  

The structure opens in the drawing area: 

 
A tab with the structure’s name is added. Multiple tabs can be open at the same time.  

7 Observe that the Transfer to bar 
(below the menu bar) now shows icons 
of the applications you can now transfer 
the structure to.  

You can use the Transfer to bar to transfer information or objects from one application to another in KnowItAll. 
The bar displays all the applications that can accept selected information or objects from the application that is 
currently in use. 
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The KnowItAll environment (continued) 

 Action Result 

8 Click SearchIt in the Transfer to bar.  The structure is transferred to the SearchIt application:  
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The KnowItAll environment (continued) 

 Action Result 

9 Click the KnowItAll Back button  
(located below the File menu). 

You are returned to the ChemWindow application. As you use different KnowItAll Informatics System applications, 
the KnowItAll Back and Forward buttons and corresponding drop-down lists become available.  

 Use the KnowItAll Back button to return to the most recently used application.  

 Use the KnowItAll Back button drop-down list to go back several steps.  

Once the KnowItAll Back button has been used, the KnowItAll Forward button and its drop-down list become 
available and can be used to move through KnowItAll applications in the opposite direction. 

10 Click ReportIt in the Transfer to bar. The structure opens in the ReportIt application, where you can create a standard report that includes this 
structure.  
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Training Files Used in This Lesson 
 2 - ATR-IR of Unknown Sample 8675309.irf 
 4 - ATR-IR of Unknown Sample 1282013.irf 
 Deformulation Example.irf 
 Mint Candy.wdf 

KnowItAll Applications Used 
 KnowItAll ID Expert 

Simple Spectral Search/Identification  
How to Use KnowItAll® ID Expert™ to Perform a Simple Spectral Search/Identification 
 
Purpose 
 
These exercises demonstrate how to use KnowItAll® ID Expert™ to Identify IR, Raman and other spectra.  
 

Objectives 
 
These exercises will teach you: 

 Perform single component searches, multiple component searches, designer drug classification & functional group analyses simultaneously and view 
results on a single screen for complete view of all possibilities for the unknown spectrum 

 De-convolute industrial material to organic and inorganic chemicals 

 How KnowItAll ID Expert’s patented optimized corrections technology can help you to find the optimal search results 

 Generate PDF report with a single click 

 

Background 

The KnowItAll ID Expert spectral identification software combined with the KnowItAll Spectral 
Libraries provides fast answers to scientists identifying unknown spectra. 

It’s easy to use. Simply open an unknown spectrum and KnowItAll ID Expert automatically 
performs single component searches, multiple component searches, possible designer drug 
classification and functional group analyses simultaneously and summarizes the results on a single 
screen to give a complete view of all possibilities for the unknown. It also can perform analysis 
using only pure organic and inorganic compound spectra, thus, breaks done industrial material into basic building blocks. If there are problems with the query 
spectrum, ID Expert has the spectral intelligence to identify issues and fix them using patented Optimized Corrections. Once the user has identified the unknown 
spectrum, a PDF report can be generated with a single click. 
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Optimized Corrections: A Breakthrough Technology for Spectral Searching 
 
Spectral searching is one of the most important tools researchers use to classify or identify materials, yet it continues to be plagued by errors and 
imperfections. During a spectral search, a sample spectrum is compared to a database of reference spectra. To ensure that an optimal match is 
found in the database, spectra can be adjusted to compensate for differences between spectra caused by variability in instruments, accessories, 
environmental conditions, and other factors. 
 
According to ASTM's guide on spectral searching1, various algorithms and manual methods exist to adjust spectra to get reasonable match scores 
when two compared spectra of the same compound differ for various reasons. While these methods may work in select cases, subtle 
discrepancies such as a shift of the X-axis are very hard to identify and correct manually. The inflexible mathematical algorithms typically 
employed do not compensate for these types of errors in spectra that are flawed.  
 
Manual corrections can be made by expert spectroscopists, but those less experienced in spectroscopy are often unaware of how to perform the 
necessary corrections on their sample spectrum to achieve the best search result. To address this growing concern, Wiley has introduced 
Optimized Corrections, a breakthrough patented technology that performs a computationally complex set of multiple corrections on all query and 
reference spectra in a search to find the optimal match between the query and each individual reference spectrum. We will demonstrate how the 
Optimized Corrections technology yields better matches between query and reference spectra than can be attained using rigid search algorithms 
alone or with manual methods to optimize spectra for searching. 
 
1 E2310-04 - Standard Guide for Use of Spectral Searching by Curve Matching Algorithms with Data Recorded Using Mid-Infrared Spectroscopy, 
2009. ASTM International Web Site. http://www.astm.org/Standards/E2310.htm (accessed March 4, 2015). 
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Example 1: 2-ATR-IR of Unknown Sample 8675309.irf 

 Action Result 

1 Open the KnowItAll ID Expert 
application, either by double-clicking its 
icon on the desktop (standalone) mode 
or by clicking its icon in the KnowItAll 
application.  

The application opens and a Windows Open dialog box pops-up.  

2 Close the Open dialog box, then 
choose File > Settings. 

The Settings form opens.  
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 Action Result 

3 Select the Optimized Corrections tab.  

 
By default, Optimized Corrections is enabled for IR, Near IR, Raman, and NMR spectra. With the Optimized 
Corrections checkbox enabled, you can specify which corrections you wish to apply for each spectral technique. 

4 Check to see if Optimized Corrections 
for IR is enabled.  

Click OK.  

The Settings form closes. The word “None” shows under Optimized Corrections on the main KnowItAll ID Expert 
window. 
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 Action Result 

5  Click New Search in the middle left 
of the window 

 Navigate to KnowItAll > Training 
Files > General Training > Files > 
Simple Spectrum Search > ID 
Expert – IR  

 Select 2 - ATR-IR of Unknown 
Sample 8675309.irf.  

 Check Imported spectrum is ATR-
IR 

 Click Open. 
 

User is prompted for a decision to send the spectrum to the secure Wiley web service for designer drug 
classification.   
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 Action Result 

6 Click either Yes or No The search proceeds automatically. 

 
 If user selected “Yes” in step 5, and the designer drug classification service return match score above 
Classification Threshold in step 2, then the Classification tab is displayed in result table, otherwise, you would 
not see it. 
The Score is the Hit Quality Index (HQI) in 100% unit – a comparison of reference spectrum to query spectrum. 

7 Click the Classification tab. 

 
This spectrum is classified as a “Steroids” spectrum.  This score measures probability for the 
classification. 
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 Action Result 

8 Click the information icon  in the 
main window’s Optimized Corrections 
section. 

The Optimized Corrections window opens.  

 
Scroll down to view information about all of the optimized corrections that were applied.  
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Example 2: 4-ATR-IR of Unknown Sample 1282013.irf 

 Action Result 

1 Click New Search.  A Windows Open dialog box displays.  

2 Open the spectral file 4-ATR-IR of 
Unknown Sample 1282013.irf. 

Click No at the prompt for submitting 
the spectrum to Wiley’s secure 
classification server. 

The search proceeds automatically: 
There is no excellent 1-Component match, and KnowItAll ID Expert automatically examines multiple component 
matches. 

3 Allow the search to complete.  The 2-Component Results tab under Search Status flashes, indicating that a good match has been found. 

4 Click the 2-Component Results tab. The Composite Spectrum, individual component spectra, and Residual Spectrum are displayed:  
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 Action Result 

5 Click Create Report below the Search 
Status section. 

The Add Comments dialog box opens.  

  
6 Click OK.  The report is created, and automatically opens in the Adobe Acrobat Reader: 
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Example 3: Deformulation Example.irf 

 Action Result 

1 Click New Search.  A Windows Open dialog box displays.  

2  Navigate to KnowItAll > Training 
Files > General Training > Files > 
Simple Spectrum Search > 
Deformulation  

 Select Deformulation Example.irf 

 Click Open 

 Click No at the prompt for 
submitting the spectrum to Wiley’s 
secure classification server. 

The search proceeds automatically: 
A perfect match is found – AKOLOUN S223-HM8.  However, it is unclear what this material is made of. 

3 Click the radio button Pure 
Compounds  

ID Expert performs another search, but only on pure organic and inorganic chemical spectra. 
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 Action Result 

4 Click the 2-Component Results tab. The Composite Spectrum, individual chemical component spectra, and Residual Spectrum are displayed.  The 
sample is possibly made up of NYLON and Calcium salt: 
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Example 4: 5 - Raman of Mint Candy.wdf 

 Action Result 

1 Click New Search.  A Windows Open dialog box displays.  

2  Navigate to KnowItAll > Training 
Files > General Training > Files > 
Simple Spectrum Search > ID 
Expert – Raman  

 Select the spectral file Raman 
Spectrum of Mint Candy.wdf 

 Click Open 

From the preview, this is not a “good” spectrum. 
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 Action Result 

4 Allow the search to complete, then 
scroll through the Search Status area.  

We have a very good match: 
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 Action Result 

6 Click the  for Optimized 
Corrections 

  
We see that all kinds of spectrum correction have been done for the first hit.  One unique to KnowItAll is the 
“Raman-specific intensity distortion. 
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 Action Result 

7 Go to File > Settings, Optimize 
Correction tab 

These are the corrections done for Raman sample and reference spectra: 

 
8 As an exercise, one can check off 

Enabled and repeat the search to see 
a very different result. 
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Training Files Used In This Lesson 
 Acetic anhydride.dx 
 Spectral Search Example.jdx.  
 Multi-Technique Sadtler Demo Database – 

Wiley [DEMO].sdbx 

KnowItAll Applications Used 
 SearchIt™  
 MineIt™  
 [optional] ProcessIt™  

 

Searching   
How to Perform a Basic Spectral Search 

 
Purpose 
 
This exercise demonstrates how to perform a spectral search. In this exercise, we will perform a single spectral search, where we compare the IR spectrum of an 
unknown compound to IR spectra in a single database.  
 

Objectives 
 
This exercise will teach you: 

 How to select databases for searching; 
 How to use search masks; 
 How to configure and perform an IR spectral search.  

 

Background 
 
Spectral searching against reference databases is frequently used in both the analysis of unknown 
compounds and compound verification.  
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Create a new search 

 Action Result 

1 Do one of the following: 

 If the SearchIt application is not 
open, navigate to the Data toolbox 
and click its icon. 

 If the SearchIt application is already 
open, click the Close button  
(located in the upper right corner) to 
close the current search. 

If SearchIt application’s User-Select (under Search Databases) tab is selected, the Selected for Searching list 
displays the databases last used.   
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Open the spectral file 

 Action Result 

1 Click the Spectrum button under 
Search Categories  

An Open dialog box appears.  

2  Navigate to KnowItAll > Training 
Files > General Training > Files > 
Searching  

 Select Acetic anhydride.dx.  

The lower part of the dialog box 
displays a preview of the selected 
spectrum. 

You can use the Files of Type filter to 
limit the display to specific types of files, 
such as JCAMP (*.dx, *.jdx), or to 
display all files (*.*).  

 Click Open. 

The spectrum is recognized as an IR spectrum and displayed in the spectral pane in the Spectrum tab.  

 
NOTE:  You can use the checkbox at the bottom to apply baseline correction to the query spectrum, if 
desired.  However, KnowItAll automatically corrects baseline. 

3 To select a different spectral file, press 
Ctrl+O.  

An Open dialog box appears. 
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 Action Result 

4 Select Spectral Search Example.jdx 
from the training files’ Searching folder. 
Click Open. 

A message box appears and offers three choices 

 
5 Click Replace existing spectrum to 

close the message box and replace the 
previously displayed spectrum.  

The new spectrum is displayed in the spectral pane.  
Note: You can also replace a search spectrum by clicking the SearchIt Close button , then clicking the 
Spectrum button in the Spectral section of the Search By pane. 
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Fine-tune before searching 

 Action Result 

1 Click Manually Edit Mask Ranges. The Spectral Include/Exclude Masks dialog box opens: 

 
Note: You can also click and drag in the Spectral pane’s Exclude Range Bar and Include Range Bar after 
closing the Spectral Include/Exclude Masks window.  

2 Deselect the Use full range checkbox 
under the list of Spectral Exclude 
Mask(s).  

The list of pre-defined exclude masks becomes available. Select some to see how they work. The use of these 
masks will be demonstrated later in this lesson. 
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 Fine-tune before searching (continued) 

 Action Result 

3 Reselect the Use full range checkbox 
under the list of Spectral Exclude 
Mask(s). 

All Spectral Exclude Masks are removed from the spectrum.  
 

4 Click OK to close the Spectral 
Include/Exclude Masks dialog box. 

 

5 Click Edit Spectrum at the bottom right 
of the spectral pane.  

The spectrum is transferred to the popped-up ProcessIt application, where you can correct potential searching 
problems and save the corrected spectrum into SearchIt spectrum pane. 

 
6 Click Cancel The spectrum is returned to the SearchIt application. Changes made in the ProcessIt IR application are not 

saved.  
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Open the search database  

 Action Result 

1 Click on User-Select under Search 
Databases 

This option allows users to select the databases they want to search. Users can also include user-created 
databases in a search. 

2 If a list of databases already appears in 
the Selected for Searching pane at 
the bottom, click Remove All to clear 
this list. 

 

3 Expand each branch in the tree 
structure on the left of the window to 
display a particular database category - 
Reference, User, Hit List - and specify 
whether network, local, or all databases 
are displayed. The available databases 
are displayed at the right of the window.  
 

The User category is shown below: 

 
Note: Your display may look different depending on whether or not you have access to databases available online. 
Click Advanced on the top right to open the Advanced Options dialog box, where you can control how you 
access online databases and add or remove local database locations. Click Refresh to update the display after 
settings are changed. 
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 Action Result 

4 Click Select by Browsing button 
located at the lower left.  

The Browse for a Database or Hit List dialog box opens.  

 
5 Navigate to KnowItAll > Training Files > 

General Training > Databases and 
open Multi-Technique Sadtler Demo 
Database – Wiley (DEMO). 

The database is displayed in the Selected for Searching list.  

 
6 If necessary, clear the All Hits check 

box and set Hit List Size Limit to 50. 
Note: When performing a spectral or 
peak search using more than two or 
three databases, it is better to limit the 
number of hits. Checking All Hits or 
using a larger value can drastically 
reduce search speed. 
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 Perform the search 

 Action Result 

1 Click Search.  The search results are automatically displayed in the MineIt application as a hit list, sorted by HQI. Both the 
unknown spectrum and the selected database spectrum are displayed.  

 
The HQI (Hit Quality Index) value measures how close the reference spectrum is to that of query. 

 TIPS  You can tag individual hits in the hit list as either "Accept", "Tentative", or "Reject" using the Hit List > Tag As 
menu option, or by double clicking in the Tag column. You can then sort the hit list based on your tags.  

 You can edit which columns in the hit list are displayed by right-clicking in the data table at the bottom left, 
selecting the Edit Columns... option, and selecting which columns you would like to display as well as the 
order in which they are displayed. 
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Perform the search (continued) 

 Action Result 

2 Click the KnowItAll Back button  
(located below the File menu). 

You are returned to the SearchIt application, where a Summary tab has been added to the main SearchIt window.  

 
3 Click the KnowItAll Forward button 

. 
You are returned to MineIt and the hit list.  
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Training Files Used In This Lesson 
 none 

KnowItAll Applications Used 
 SearchIt™ 

 

Searching   
How to Create Search Profiles 

 
Purpose 
 
This exercise demonstrates how to use search profiles. 

 

Objectives 
 
This exercise will teach you: 

 How to apply a search profile; 
 How to create a search profile. 

 

Background 
 
Search Profiles are pre-defined combinations of search parameters such as Databases and Hit 
List Size Limit that can be stored for later use. Using search profiles makes searching easier, 
especially when the same type of search is repeated.  
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Apply a pre-defined search profile 

 Action Result 

1 Do one of the following: 

 If the SearchIt application is not 
open, navigate to the Data toolbox 
and click its icon. 

 If the SearchIt application is already 
open, click the SearchIt Close 
button  to close the current search 

The SearchIt application’s Databases tab is displayed, and the Selected for Searching list displays the 
databases last used.   

 
2 If databases are already selected for 

searching, click Remove All to clear 
the selections. You can also double-
click individual entries to remove them 
from the list.  

 

3 If necessary, choose View > Profile 
Toolbar to display Search Profiles 
tools. 
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 Action Result 

4 Select the IR_Polymers profile. Polymer databases are displayed in the Selected for Searching list.   
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Create a new search profile 

 Action Result 

1 Click the SearchIt Close button , then 
click Remove All to clear the contents 
of the Selected for Searching list. 

The Databases tab is displayed. The Selected for Searching list is empty. 

2 
Click the Add a New Profile button  
on the Profile toolbar. 

The New Profile dialog box opens: 

 
3 Type in the name of the new profile 

[IR_Polymers_2],  

Click OK.  

The new profile name is displayed in the Search Profiles text box. 

4 Specify IR in the Limit to spectral 
technique drop-down list. 

Only databases with IR spectra are displayed in the Available for Searching list. Note that Multi-Technique 
Sadtler Demo Database – Wiley is included in the list because it includes IR spectra. 

5 In the Available for Searching list, 
click to select IR – Polymers, Hummel 
– Wiley (DB Code HUX) 

Click Add. 

The IR – Polymers, Hummel – Wiley database is added to the Selected for Searching list.  

6 In the Available for Searching list, 
double-click IR –  Polymers & 
Monomers (Basic) 1 – Wiley (DB 
Code BPX). 

The IR – Polymers & Monomers (Basic) 1 – Wiley database is added to the Selected for Searching list. 
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 Action Result 

7 Continue adding databases BMX, CRX, 
DAX, FRX, and NEX. 

 

8 On the Databases tab, change the Hit 
List Size Limit to 10.  

 

9 Click the Save Current Profile button 

on the Profile toolbar. 

A message box asks if you wish to overwrite the current profile. Click Yes to save the new profile. 

10 Close the current search, then select 
the newly-created IR_Polymers_2 
search profile.  

The databases and search settings associated with this profile are displayed.  
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Training Files Used in This Lesson 
 Ethyl acrylate.dx 

KnowItAll Applications Used 
 SearchIt™ 
 MineIt™ 

 

Searching   
How to Search a Database of Spectra or Chromatograms by Peak 

 
Purpose 
 
This exercise demonstrates how to perform a peak search. 

 

Objectives 
 
This exercise will teach you: 

 How to configure a peak search.  
 

Background 
 
The SearchIt application provides the capability of using peak information to perform a search of 
spectral or chromatographic data. This allows users to compare peak tables from databases to a 
peak table that you enter or extract from a spectrum. 
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Configure and perform a peak search 

 Action Result 

1 Do one of the following: 

 If the SearchIt application is not 
open, navigate to the Data toolbox 
and click its icon. 

 If the application is already open, 
click the Close button  to close 
the current search 

The SearchIt application’s Databases tab is displayed, and the Selected for Searching list displays the 
databases last used.   
 

2  If databases are already selected 
for searching, click Remove All to 
clear the selections. 

 Set Limit to spectral technique to 
IR. 

 Click Add All.  
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 Action Result 

3  Under Search Categories click 
Peaks.  

 Choose IR in the pop-up dialog. 

 Click OK. 
 

4 Click Open Spectrum or Structure 

 
5  Navigate to KnowItAll > Training 

Files > General Training > 
Databases  

 Open Ethyl acrylate.dx. 

The spectrum is displayed.  
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 Action Result 

6 Click Pick. The peak table is created based on the current settings. 

 
 TIP You can remove a peak from the peak table by selecting the peak and clicking the delete button or by double-

clicking it in the peak bar. Similarly, you can also add or edit peaks using the corresponding buttons at the bottom 
of the table..  
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 Action Result 

7 Click Search.  Search results are automatically displayed in the MineIt application.  

 
For each entry, the Spectral pane displays the hit list spectrum along with the peaks used to perform the search. 
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Training Files Used In This Lesson 
 Include – Exclude Range Example.jdx  

KnowItAll Applications Used 
 SearchIt™  
 MineIt™ 

 

  
Searching   
How to Search Spectral Databases Using a Limited Range in a Spectrum 

 
Purpose 
 
This exercise demonstrates how to search spectral databases using a limited spectral range with the KnowItAll Informatics System’s SearchIt™ application.  
 

Objectives 
 
This exercise will teach you: 

 How to use the Include Range bar when configuring a spectral search; 
 How to use the Search Masks dialog box when configuring a spectral search.  

 

Background 
 
Using a limited range spectral search is slightly faster because fewer points are needed for 
computation. Using a limited range also focuses a spectral search on feature-rich areas such as 
the fingerprint region in the IR below 1500 wavenumbers, and can be used in place of spectral 
subtraction by ignoring regions where impurities have peaks. 
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Configure a spectral search 

 Action Result 

1 Do one of the following: 

 If the SearchIt application is not 
open, navigate to the Data toolbox 
and click its icon. 

 If the SearchIt application is already 
open, click the SearchIt Close 
button  to close the current search 

The SearchIt application’s Databases tab is displayed, and the Selected for Searching list displays the 
databases last used.   
 

2 If databases are already selected for 
searching, click Remove All to clear 
the selections.  

 

3 Click Reference – Licensed in the tree 
control.  

Name, DB Code, and Location are displayed for the available databases.  

Note: Click Advanced to specify Server Settings, define local database paths, and find local databases. Expand 
the tree to view and select network and local database locations. You can also select user databases and hit lists 
for searching. Finally, you can locate a specific database by clicking Select by Browsing. 

4 Click Add All. Titles and locations are displayed in the Selected for Searching list.  

5 Click Spectrum under Search 
Categories 

An Open dialog box appears. 
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 Action Result 

  Navigate to KnowItAll > Training 
Files > General Training > Files > 
Searching  

 Open Include -Exclude Range 
Example.jdx. 

Note: You can use the Files of Type 
filter to display JCAMP files (or all files). 

The spectrum is displayed 
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Use the Include Range bar 

 Action Result 

1 Move the cursor over the Include 
Range Bar beneath the spectrum. 

The cursor changes to a double pipe with a plus sign next to it:  

 
2 Click, drag, and release within the 

Include Range Bar to define an 
Include region. 

The Include region is bright green in the Include Range Bar; the included spectral region has a white background. 
Spectral regions that will not be included in the search have a gray background.  

 
Using the Include Range feature allows you to set one or more ranges to be included in a spectral search. This 
feature is primarily used on a per search basis. Although the ranges set using this method will be remembered 
until they are changed, the ranges are not permanently saved. 
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 Action Result 

3 Click and drag to define a second 
Include region. 

 

4 To move a region, click within the 
region on the Include Range Bar and 
drag to a new location.  
 

 

 
 TIP To remove a single region, either click within the region on the Include Range Bar and drag to either side away 

from the spectral pane, or right-click within the region and choose Yes on the message box that opens.  
To remove all regions, click the garbage can icon at the right end of the Include Range Bar.  

5 To re-size a region, move the cursor 
into the Include Range Bar and 
position the cursor over an endpoint, 
then drag and release.  

The cursor changes to a cross with a double arrowhead: 
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Use the Search Masks dialog box 

 Action Result 

1 Click Manually Edit Mask Ranges. The Spectral Include/Exclude Masks dialog box opens:  

 
Note that any Include regions defined using the Include Range Bar are displayed in the list of Spectral Include 
Mask(s). However, if Use full range is checked, these regions will not be used. 

2 Click to select one of the include 
regions, then click Remove.  
Note: You can select either the high or 
low value to remove an Include region. 

The region is removed from the list.  

3 Click to select the High Range value in 
the remaining Include region and type 
in ‘1750.’ 
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 Action Result 

4 Click to select the Low Range value in 
the remaining Include region and type 
in ‘500.’ 

 
5 Click Add to create another Include 

region. 
A text box with cursor appears in the High Range column: 

 
6 Type ‘3650’ in the new High Range 

text box, then click in the Low Range 
column and type ‘3050.’ 
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Use the Search Masks dialog box (continued) 
 Action Result 

7 Click OK.  The dialog box closes, and the search spectrum is displayed with the re-defined Include regions: 

 
8 Click Search. The search is performed, and results are automatically displayed in the MineIt application as a hit list. 

 
Clicking on the information icon  in the results table displays Optimized Corrections that have been performed. 
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Use the Search Masks dialog box (continued) 

 Action Result 

9 Close the Optimized Corrections 
window, then use the KnowItAll Back 
button to return to the SearchIt 
application.  
Click Advanced Settings on the IR 
Spectrum tab. 

The Advanced Settings dialog box opens. 

 
Use this dialog box to enable and customize Optimized Corrections.  
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Training Files Used In This Lesson 
 Include-Exclude Range Example.jdx  

KnowItAll Applications Used 
 SearchIt™  
 MineIt™ 

 

Searching   
How to Search Spectral Databases Using a Mask to Exclude Regions in Your Search 

 
Purpose 
 
This exercise demonstrates how to create masks to exclude regions in a spectral search.  
 

Objectives 
 
This exercise will teach you: 

 How to create and use Exclude Masks when configuring a spectral search.  
 

Background 
 
Exclude masks allow you to ignore regions during spectral searching, and can be defined for a 
variety of compounds such as solvents or impurities. Such masking allows for an easy method to 
remove these regions from consideration during a search. 

Unlike Include regions, which are not permanent, exclude masks can be saved and re-used. 
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Configure a spectral search 

 Action Result 

1 Do one of the following: 

 If the SearchIt application is not 
open, navigate to the Data toolbox 
and click its icon. 

 If the SearchIt application is already 
open, click the SearchIt Close 
button  to close the current search 

The SearchIt application’s Databases tab is displayed, and the Selected for Searching list displays the 
databases last used.   
 

2 If databases are already selected for 
searching, click Remove All to clear 
the selections.  

 

3 Click Reference – Licensed in the tree 
control.  

Name, DB Code, and Location are displayed for the available databases.  

Note: Click Advanced to specify Server Settings, define local database paths, and find local databases. Expand 
the tree to view and select network and local database locations. You can also use user databases and hit lists for 
searching. Finally, you can locate a specific database by clicking Select by Browsing. 

4 Select IR using the Limit to spectral 
technique control.  

Only databases having IR spectra are displayed.  

Note: Many of the databases have only IR spectra, but others – such as the Multi-Technique Sadtler Demo 
Database – Wiley – include other types of spectra, and structures. 

5 Click Add All. Titles and locations are displayed in the Selected for Searching list.  

6 Click Spectrum under Search 
Categories 

An Open dialog box appears 

7  Navigate to KnowItAll > Training 
Files > General Training > Files > 
Searching.   

 Open Include-Exclude Range 
Example.jdx. 

Note: You can use the Files of type 
filter to display JCAMP files (or all files). 

The spectrum is displayed in the IR Spectrum tab.  
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Use the Search Masks dialog box 

 Action Result 

1 Click Manually Edit Mask Ranges. The Spectral Include/Exclude Masks dialog box opens.  

 
2 Uncheck Use full range under the list 

of Spectral Exclude Mask(s), then 
click to select the Carbon dioxide 
exclude mask. 

Excluded regions are highlighted in bright red on the Exclude Range Bar, and in gray in the spectrum. The carbon 
dioxide exclude mask includes two regions. 
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 Action Result 

3 Click Edit on the Spectral 
Include/Exclude Masks dialog box. 

The Exclude Mask Settings dialog opens: 

 
4 Click Add. A text box appears under Available Exclude Mask Settings. 
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 Action Result 

5 Type in Carbon monoxide, then click 
outside the text box. 

 

6 With Carbon monoxide selected in the 
list of Available Exclude Mask 
Settings, click Add under the list of 
Exclude Regions, or click under Low 
Range.   

A text box appears under Exclude Regions. 

 
 TIP Alternatively, you can also manually set exclude ranges using the Exclude Range Bar and clicking and dragging 

to select regions. See the section above on How to Search Spectral Databases Using a Limited Range in a 
Spectrum. Manually setting the exclude range works in exactly the same way as manually setting the include 
range. 
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 Action Result 

7 Type in low and high range values 
(2050 and 2240), then click OK. 

The Exclude Mask Settings dialog box closes, and the new carbon monoxide mask is added to the list of exclude 
masks: 

 
8 Select the new Carbon monoxide 

mask, then click OK to close the 
Spectral Include/Exclude Masks 
dialog box. 

The dialog box closes, and the search spectrum is displayed with the newly-defined exclude region: 
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 Action Result 

9 Click Search. The search results are automatically displayed in the MineIt application as a hit list.  
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Training Files Used In This Lesson 
 Unknown Mixture 01011969.jdx  

KnowItAll Applications Used 
 SearchIt™ 
 MineIt™ 
 ProcessIt™ IR 

 

Searching   
How to Subtract One Spectrum from Another 

 
Purpose 
 
This exercise demonstrates how to use the spectral subtraction feature in the KnowItAll Informatics System.  
 

Objectives 
 
This exercise will teach you: 

 How to use the spectral subtraction feature in KnowItAll. 
 

Background 
 
You can use the ProcessIt™ applications to perform a point-by-point subtraction of one spectrum 
from another. This capability is useful when analyzing mixtures or composite spectra. 
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Set up a spectral search against a mixture 

 Action Result 

1 In the SearchIt application, set up and 
perform an IR spectral search using 
Unknown Mixture 01011969.jdx 
located in KnowItAll > Training Files 
> General Training > Files > 
Searching folder, and the Multi-
Technique Sadtler Demo Database – 
Wiley. 

TIP In the SearchIt application, click on 
the DB Code column to sort databases 
alphabetically by code in ascending or 
descending order.  

Results are displayed in the MineIt application. The first hit is cyclohexane. Both spectra, the query and the first 
hit, are displayed in the spectral pane.  
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Create a difference spectrum 

 Action Result 

1 With the hit list displayed in MineIt and 
the first record selected, click ProcessIt 
in the Transfer to bar.  

The Import of Multiple Spectra dialog box opens.  

 
Both the query spectrum and the first hit are displayed.  
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 Action Result 

2 Click Select All, then click OK on the 
Import of Multiple Spectra dialog box.  

Both spectra – the mixture and the first hit, cyclohexane - are transferred to the ProcessIt IR application.  

 
Note: Use spectrum toolbar buttons to adjust the display. The Stacked display is preferable to Offset or Overlay for 
spectral subtraction. 
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 Action Result 

3 Choose Process > Add/Subtract 
Spectrum.  
Note: You can also use the toolbar 

button . The command is not 
available unless two or more spectra 
are open.  

The Add/Subtract dialog box opens.  

 
The active spectrum is assumed to be the reference spectrum. 

4 Make sure the mixture spectrum is the 
Experimental Spectrum, and 
cyclohexane is the Reference 
Spectrum. If needed, change these 
assignments using either of the drop-
down lists. 

 

5 Check Scale to Reference Spectrum, 
set Factor to 1, and make sure the 
Subtract radio button is selected. 
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 Action Result 

6 Click Preview.  The subtracted spectrum is displayed above the other two. Note the presence of negative peaks in the difference 
spectrum.  

 
7 On the Add/Subtract dialog box, adjust 

Factor to 0.6.  
Negative peaks in the difference spectrum disappear.  
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Create a difference spectrum (continued) 

 Action Result 

8 Click Replace. A message box opens, and asks whether negative values should be truncated to zero.  

9 Click Yes.  The mixture spectrum is replaced by a difference spectrum, Unknown Mixture 01011969 - SRX #3, Cyclohexane.  
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Repeat the search using the difference spectrum 

 Action Result 

1 Click SearchIt in the Transfer to bar.  The Import of Multiple Spectra dialog box opens: 

 

2 De-select DEMOX #12 Cyclohexane 
so that only the difference spectrum is 
selected. 

Click OK. 

A message box opens: 

 
3 Click Start a new search.  The difference spectrum is loaded in SearchIt. 



 

108658‐ REV20201102  Copyright © 2020 by John Wiley & Sons, Inc. All rights reserved.   

KnowItAll Training   Searching - 46 

 

 Action Result 

4 Click the Databases tab and make 
sure the Multi-Technique Sadtler 
Demo Database – Wiley is 
selected for searching 

Click Search. 

Results are displayed in the MineIt application. The first hit is benzene, the other component of the mixture: 
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Training Files Used In This Lesson 
 tryptophan.dsf 
 benzenethiol.dsf  

KnowItAll Applications Used 
 SearchIt™ 
 MineIt™ 
 ChemWindow®  

 

Searching   
How to Perform a Structure Search 

 
Purpose 
 
This exercise demonstrates how to perform a structure search using the SearchIt™ application.   

 

Objectives 
 
This exercise will teach you: 

 How to perform an exact match structure search; 
 How to perform a substructure search. 

 

Background 
 
In the SearchIt application, scientists can use a structure fragment as a search term to locate 
chemical structures containing that structural skeleton. This capability is useful for retrieving 
structure fragments because a substructure search always analyzes the entire molecular structure 
of a compound - not just the largest fragment. 
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Configure an exact structure match search 

 Action Result 

1 Do one of the following: 

 If the SearchIt application is not 
open, navigate to the Data 
toolbox and click its icon. 

 If the SearchIt application is 
already open, click the SearchIt 
Close button  to close the 
current search 

The SearchIt application’s Databases tab is displayed, and the Selected for Searching list displays the databases 
last used.   
 

2 If databases are already selected 
for searching, click Remove All to 
clear the selections.  

 

3 Set Limit to Spectral Technique 
to MS. 

Only databases with MS spectral data are displayed. 

4 Select database MTX for searching.   

5 Click Structure under Search 
Categories. 
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 Action Result 

6  Click Open file on the Structure 
tab. 

 Navigate to KnowItAll > Training 
Files > General Training > Files > 
Searching.  

 Open Tryptophan.dsf. 

The structure is displayed in the Structure tab.  

 
Note: You can also click Draw/Edit to create a structure using the ChemWindow application. 
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Perform an exact structure match search 

 Action Result 

1 Select Exact Match under Search 
Mode, then click Search. 

Exact matches are displayed in the MineIt application.  
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Configure and perform a substructure search 

 Action Result 

1 Click the KnowItAll Back button to 
return to SearchIt, then click to select 
the Structure tab. 

 

2 Select Substructure Search, then click 
Search. 

Note: Rather than finding only exact 
matches for the search structure, the 
substructure search returns records 
that contain the query structure as a 
part of the database structure. 

The substructure search produces more hits than the exact match search. Note that the original hit list is still 
available, and can be accessed by clicking the appropriate tab (at the lower left corner). 
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Configure and perform a similarity search 

 Action Result 

1 Click the KnowItAll Back button to 
return to SearchIt 

 

2 Click the Similarity Search radio 
button. Accept the default scoring 
method, Tanimoto. 

 

3  Click Search. The results are displayed in the MineIt application: 

 
The first hit is the exact structure. The second hit, toluene, is a similar structure.  
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Training Files Used in This Lesson 
 Spectral Search Example 

KnowItAll Applications Used 
 SearchIt™  
 MineIt™ 

 

Searching   

All Compounds and Pure Compounds Database Selections 

 
Purpose 
 
This exercise demonstrates how to use the All Compounds and Pure Compounds Database Selections 

  

Objectives 
 
This exercise will teach you: 

 How to use All Compounds and Pure Compounds Database Selections. 
 How to interpret the search result. 

 

Background 
 
All Compounds and Pure Compounds database selections link data by structure, name, InChI, 
CAS Registry Number or synonym. 
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Configure and perform an All Compounds search 

 Action Result 

1 Do one of the following: 

 If the SearchIt application is not 
open, navigate to the Data 
toolbox and click its icon. 

 If the SearchIt application is 
already open, click the SearchIt 
Close button  to close the 
current search. 

The SearchIt application’s Databases tab is displayed, and the Selected for Searching list displays the databases 
last used.   

2 Select the All Compounds option 
under Search Databases 

 

3  Click Spectrum under Search 
Categories. 

 Open Spectral Search 
Example.jdx 
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 Action Result 

7 Click Search.  The search is performed and results are displayed in the MineIt application.  

 
Compared to the User-Select database search, you will see additional information related to the hit: 

 Replicates are displayed in the upper-left panel.  They do not participate in this search, and navigating 
through them does not change the value of HQI (Hit Quality Index).  The bold ID signifies the hit 
spectrum. 

 Other spectrum information related to the hit compound is displayed in tabs under the spectrum pane. 

 User-Select - User selects which databases to search. This is where one can include user databases in a search. 
 All Compounds – All licensed reference databases.  Records are linked by structure, name, InChI, CAS Registry Number or synonym. 
 Pure Compounds - All Compounds with the exclusion of commercial compounds.  
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Training Files Used In This Lesson 
 Unknown IR.jdx  
 Unknown Raman.jdx  

KnowItAll Applications Used 
 SearchIt™  
 MineIt™ 

 

Searching   

How to Perform a Multi-Technique Spectral Search 

 
Purpose 
 
This exercise demonstrates how to perform a multi-technique spectral search using the KnowItAll Informatics System.  

 

Objectives 
 
This exercise will teach you: 

 How to configure a multi-technique spectral search. 
 How to analyze the results of a multi-technique search. 

 

Background 
 
A multi-technique spectral search permits the optimization of chemical similarity based on several 
analytical techniques to maximize the chemical knowledge obtained on the unknown compound. 
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Configure and perform a multi-technique spectral search use User-Select Search Databases option  

 Action Result 

1 Do one of the following: 

 If the SearchIt application is not 
open, navigate to the Data toolbox 
and click its icon. 

 If the SearchIt application is already 
open, click the SearchIt Close 
button  to close the current 
search. 

The SearchIt application’s Databases tab is displayed, and the Selected for Searching list displays the 
databases last used.   

2 Select User-Select under Search 
Databases option 

 

3  If databases are already selected 
for searching, click Remove All to 
clear the selections.  

 Add all IR and Raman databases to 
Selected for Searching. 

 

4  Click Spectrum under Search 
Categories. 

 Navigate to KnowItAll > Training 
Files > General Training > Files > 
Searching.  

 Open Unknown IR.jdx 

 



 

108658‐ REV20201102  Copyright © 2020 by John Wiley & Sons, Inc. All rights reserved.   

KnowItAll Training   Searching - 58 

 

 Action Result 

5  Click the new Spectrum under 
Search Categories. 

 Open Unknown Raman.jdx. 
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 Action Result 

6 Click Search.  The search results are displayed in the MineIt application.  

 
Because this was a multi-technique search, the Database pane’s Plot tab automatically displays a scatter plot 
representing HQI values for the two spectral techniques. The point with the highest HQI values is selected at the 
upper right.  
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Examine the search results 

 Action Result 

1 Click the Table tab in the Database 
pane.  

The corresponding database entries are displayed: 
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Configure and perform a multi-technique spectral search with All Compounds Search Databases option 

 Action Result 

1 Do one of the following: 

 If the SearchIt application is not 
open, navigate to the Data toolbox 
and click its icon. 

 If the SearchIt application is already 
open, click the SearchIt Close 
button  to close the current 
search. 

The SearchIt application’s Databases tab is displayed, and the Selected for Searching list displays the 
databases last used.   

2 Check All Compounds under Search 
Databases option 

 

3  Click Spectrum under Search 
Categories. 

 Open Unknown IR.jdx. 
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 Action Result 

4 Click Search.  The search results are displayed in the MineIt application.  

 
Because this was a multi-technique search, the Database pane’s Plot tab automatically displays a scatter plot 
representing HQI values for the two spectral techniques. The point with the highest HQI values is selected at the 
upper right.  
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Compare the search result with that from User-Select search 

 Action Result 

1  Compare the scatter plot of the User-Select database search (top) and that of All Compound search (bottom) 

 

 
We can see that more spots are in this region. 
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 Action Result 

 Examine the extra spots 

 
We can see that they are the stereoisomers whose IR and Raman spectral records are linked not by structure, but 
by other features in the record (name, InChI, CAS Registry Number or synonym). 
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 Action Result 

  

 
The above is another stereo-isomer. 
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Training Files Used In This Lesson 
 Mixture of Two Steroids – ATR-IR.irf 

KnowItAll Applications Used 
 SearchIt™ 
 MineIt™ 

 

Mixture Analysis   
How to Analyze Mixture Spectra 

 
Purpose 
 
This exercise demonstrates how to perform a mixture analysis using the KnowItAll Informatics System’s SearchIt application.  
 

Objectives 
 
This exercise will teach you: 

 How to configure a mixture analysis; 
 How to interpret the results of a mixture analysis.  

 

Background 
 
The spectral analysis of mixtures in experimental data is a challenging task. Manual 
separation of spectral components, even when they are known in advance, is a tedious job. 
Attempting to do this analysis in an automated fashion creates a whole new level of 
challenges.  

This chapter introduces how to use SearchIt application to perform Mixture Analysis. 
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A typical mixture analysis work flow 

 Action Result 

1 Navigate to the Data toolbox and open 
the SearchIt application 

Check Spectrum, and in the resulting 
Open dialog box navigate to 
KnowItAll > Training Files > 
General Training > Files > Mixture 
Analysis and open Mixture of Two 
Steroids - ATR-IR. 

 Set Search Method to Correlation  

 Click on User-Select under Search 
Databases 

 Set Limit to spectral technique to 
IR 

 Click Add All at the bottom of 
Available for searching menu  
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 Action Result 

1 Do the following: 

 Set Search Method to Correlation  

 Click on User-Select under Search 
Databases 

 Set Limit to spectral technique to 
IR 

 Click Add All at the bottom of 
Available for searching menu 

 

2 Click Search. Wait for the search to complete.  
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 Action Result 

   One component search result returns to MineIt application. 

 
Obviously, the sample is a mixture. 

3 Highlight the 1st hit. 

Edit > Copy Active Spectrum 
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 Action Result 

4 Go back to SearchIt,  

Click the Spectrum FTIR button to 
bring up the query spectrum. 

Update the Number of components to 
2 (Mixture).  

 

The Included Components and Excluded Components checkboxes show up now. 

5 Check the Included Components 

Paste the copied spectrum.  
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 Action Result 

6 Click the Spectrum FTIR button to 
bring up the query spectrum.  

Click Search.  

 
Now we have a good two-component match. 

Note:  Each composite spectrum (row 1) is accompanied by the individual component spectra (middle rows) that 
comprise the composite, as well as the residual spectrum (last row) – the difference between the query spectrum 
and the composite. The composite spectra are ranked by how closely they resemble the query spectrum. A 
relatively flat residual spectrum indicates that the software has correctly identified the individual components of the 
mixture.  The Weight value for each component spectrum indicates how much it contributes to the composite 
spectrum. 
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 Action Result 

7 The circle in Exclude column can be 
checked to exclude a component from 
consideration.   

Check to exclude DWX 907.  Repeat 
Search button shows up for user to 
repeat Mixture Analysis without 
considering DWX 907 
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 Action Result 

8 Click Repeat Search. The new result does not contain excluded DWX 907: 
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Notes: 

 You do not have to specify Included 
or Excluded components to perform 
a mixture analysis.  You can simply 
open a spectrum in SearchIt and 
specify Number of components to a 
value larger than 1. 

 

 You can add Included or Excluded 
components from files by clicking the 
Add button. 

 

 You can exclude spectrally similar 
records. 

 

 

 

 

 



 

108658‐REV20201102  Copyright ©2020 by John Wiley & Sons, Inc. All rights reserved. 

KnowItAll Training   Mixture Analysis - 12 

Add all components together 

 Action Result 

1  In the Data toolbox, open the 
SearchIt application 

 Check Spectrum 

 In the resulting Open dialog box, 
navigate to KnowItAll > Samples > 
Mixture Analysis > IR Examples  

 Open Mixture of Two Steroids - 
ATR-IR. 

 Set Search Method to Correlation. 

 Set Number of components to 2 
(Mixture): 

 

2 Check Included Components 

Add following files from KnowItAll > 
Training Files > General Training > 
Files > Mixture Analysis > 
Components folder: 

 Epiandrosterone ATR-IR 

 Ethisterone ATR-IR 

Note: use ctrl key to select multiple files 
in the Open dialog box.  
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 Action Result 

3 Click Search. 

Note: toggle between different spectra 
display modes by selecting available 
options from View > Display Mode. 

 
In this case, KnowItAll simply returns possible combinations of two provided components, without going through a 
database search. 
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Training Files Used in This Lesson 
 IR/Ethyl acetate.dx  
 Raman/Ethyl acetate.irf 
 BatchImportProperties.csv  
 Spectral files from the Batch Import Spectra 

folder 
 MSDS Web Link.txt 
 Ethyl acetate MSDS.pdf 
 Spectral files from the PubChem/Raman folder 

KnowItAll Applications Used 
 MineIt™ 
 ChemWindow®  
 BrowseIt™ 

Create Databases   
How to Build Your Own User Databases of Multiple Analytical Techniques 
 
Purpose 
 
This exercise demonstrates how to use KnowItAll’s MineIt™ Database Building feature to create searchable user databases that include multiple analytical 
techniques. You can also customize properties displayed, create user properties and display profiles.  
 

Objectives 
 
This exercise will teach you: 

 How to create a user database; 
 How to add spectra to a user database; 
 How to add structures to a user database; 
 How to add user properties;  
 How to perform above tasks in batch; and 
 How to create and use a MineIt display profile.  

 

Background 
 
Generating user databases protects intellectual property and promotes sharing of information 
within an organization. Ultimately, researchers can improve their analyses.  
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Create a user database 

 Action Result 

1 Navigate to the Data toolbox and open 
the MineIt application by clicking the 
MineIt/Create Database icon.  

The MineIt application opens. 

2 Choose Database > New. The New Database Creation dialog box opens. 

 
3 Select Create on local system. The new database is saved locally. 

4  Click Browse.  

 Create a folder named Databases 
on a local drive 

 Open the folder, then type in the file 
name quality_control  

 Click Save. 

The *.sdbx extension is added automatically.  
Note: The SDBX database format allows spectra to be stored without conforming to a fixed range and resolution. 
This allows reference spectra to be offered at higher resolution, and allows users to store original spectra as 
produced. 

5 Type Quality Control in the Database 
Name text box. 
Note: The file name is used if no other 
name is specified.  

 



 

108658‐ REV20201102  Copyright ©2020 by John Wiley & Sons, Inc. All rights reserved. 

KnowItAll Training   Create Databases - 4 

Create a user database (continued) 

 Action Result 

6 Type QCLab in the Database 
Abbreviation text box. 

Note: The abbreviation must be 3-7 
characters long. 

 

7 Enter Version number and the First 
(starting) ID, and type in copyright 
messages. 

Note: You can use the Windows 
Character Map (Programs > 
Accessories > System Tools in 
Windows 7) to copy and paste in the 
copyright symbol. 

 
8 Click OK. The new database has been created to receive your data. The Database Abbreviation ‘QCLab’ appears on the 

database tab below the database pane (lower left), and copyright information appears in the status area (lower 
edge of the main window). 
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Add the first record to the user database 

 Action Result 

1 Create the first database record by 
importing a spectrum:  

 Choose File > Import or press 
Ctrl+I. 

 Navigate to KnowItAll > Training 
Files > General Training > Files > 
Creating Databases > IR  

 Open Ethyl acetate.dx  

Note: Use the Files of type filter to 
locate IRF, JCAMP, and many other 
specific spectral files. 

A Windows Open dialog box appears.   
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 Action Result 

2 Click Open.  The Property Import Selection dialog box opens: 

 
This dialog box appears when you transfer information into a user database. All available properties are shown. 
Select each property in turn; then use the checkboxes to define the action for each property. 

3 Click OK. The dialog box closes. The spectrum has been added to the user database as the first record: 
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Add a chemical structure and properties to the first database record 

 Action Result 

1 With the first record selected, double-
click the Structure/Properties pane at 
the top right of the window (Double-
click to edit structure in 
ChemWindow).   

The ChemWindow application pops up.  Alternatively, one can use Transfer to: to go to the ChemWindow 
application. 

 

2 Use the drawing tools to create this 
structure 
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 Action Result 

3 Click Save.  The structure is added to the first record, and is displayed both in the Chemical Structure column in the 
Database pane and the Structure/Properties pane.  

 
NOTE: Some chemical properties such as InChI, InChIKey, Molecular Weight, etc., can be set to be automatically 
calculated when a structure is saved in a record. 

4 Click Add at the bottom of the 
Structure/Properties pane.  

The Property dialog box appears.  

5 Use the drop-down list to select the 
property you wish to add – Comments. 
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 Action Result 

6 Click OK.  The Property dialog box closes, and the name and value of the added property appear in the 
Structure/Properties pane.  

 
 TIP You can select multiple database records and use the Add or Edit button at the bottom of the 

Structure/Properties pane to input the same value for a field. 
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Add user properties 

 Action Result 

1 Choose Database > Define User 
Property Fields 

The User Property Fields dialog box opens.  
 

2 Click Add. 
Use the drop-down list to set Type to 
text. 

The Property Field Definition dialog box opens.  

 
Note: Which controls are available depends on which type of field is specified: numeric, text, or enumeration. 

3 Click OK, then Close  

4 Click Add in the Structure/ 
Properties pane.  
 

The Property dialog box opens. 
 
Note: Choose View > Windows/Tables > Structure/Properties Table or press Alt+3 if the pane is not visible.  

5 Click the down arrow to display all 
available properties. 

Both pre-defined and user-defined properties are displayed. User-defined properties are at the beginning of the 
list.  

6 Select SampleID. The Value text box is added to the dialog. 
Note: Which text boxes are added depends on whether the property is numeric, text, or enumeration. 
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7 Type ‘1234’ in the Value text box. 

 
8 Click OK. The dialog box closes. The property SampleID with value 1234 is added to the Structure/Properties pane for the 

first record.  
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 Action Result 

9 Repeat steps 1-10 to create the user 
property WebLink and display it in the 
Structure/Properties pane.  
Type 
‘https://pubchem.ncbi.nlm.nih.gov/comp
ound/ethyl-acetate’ 
in the Property dialog box’s Value 
field.  
Note: You can copy the text string from 
MSDS Web link.txt in the KnowItAll 
Training files. 

The property WebLink with a web address is added to the Structure/Properties pane for the first record.  

 
10 Click the web address in the 

Structure/Properties pane. 
The web page opens in the BrowseIt application.  

 
11 Click the KnowItAll Back button to 

return to the MineIt application.  
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Add another spectrum (Raman) to the first database record 

 Action Result 

1 Make sure the first database record is 
selected, then choose File > Import. 

The Open dialog box with preview pane appears. 

2 Navigate to KnowItAll > Training Files 
> General Training > Files > Creating 
Databases > Raman  

Open Ethyl acetate.irf.  

The Property Import Selection dialog box opens.  

 
This dialog box appears when you transfer information into a user database. All available properties are shown.  
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Add another spectrum (Raman) to the first database record (continued) 

 Action Result 

3 Click OK.  A new Raman tab is added to the Spectral pane for the display of the Raman spectrum.  

 
4 Switch between spectra by using the 

tabs at the bottom left of the spectral 
pane. 

 

5 You can also switch between spectra 
by clicking the arrow in the Database 
pane’s Spectrum column.  
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Add an attachment to the first database record 

 Action Result 

1 With the first database record selected, 
click the Attachments tab in the 
Structure/Properties pane.  

The Attachments tab is empty: 

 
2 Choose File > Import Attachment(s)… A Windows Open dialog box is displayed. 

3 Navigate to KnowItAll > Training Files > 
General Training > Files > Creating 
Databases and select Ethyl acetate 
MSDS.pdf, then click Open. 

An icon is added to the Attachments tab: 
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Add an attachment to the first database record (continued) 

 Action Result 

4 Double click the icon in the 
Attachments tab.  

The document opens in its native application – in this case, Adobe Acrobat. 

 
Note: Any type of file can be added to a record in a user database using the Attachments tab. In addition, you 
can export an attached file by choosing File > Export > Attachments.  
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Create a new MineIt display profile 

 Action Result 

1 Click the Add a New Profile button  
in the Profile toolbar. 

The New Profile dialog box opens: 

 
 

2 Type in the profile name QC Lab and 
click OK.  

This layout is now available to apply to any database or hit list display in the MineIt application.  

 TIP When creating a database and to ensure individual users in your laboratory consistently enter all pertinent 
information into databases, you should set up preferred properties.  
To do so, go to File > Preferences. In the Preferences dialog, select the Property Display tab. Click on Deselect 
All to clear the properties; then select the properties that you want entered and the order of those properties. 

 
Then the user will enter the information required for that profile. If there is no information for a particular property, it 
will not appear under All Properties. 
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Batch Import: many spectra, many records, import properties from a spreadsheet 

 Action Result 

1 Create a new empty database as in the 
above example. 

 

2 Choose File > Batch Import, to open 
the Select Files dialog box.  
Navigate to KnowItAll > Training Files > 
General Training > Files > Creating 
Databases > Batch Import Spectra, 
select all spectral files in the folder and 
click OK. 
Note: Check the box next to a folder 
name to select all files in the folder.  

 
A record is created in the new database for each spectral file.  
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3  Choose File > Import 

 Navigate to KnowItAll > Training 
Files > General Training > Files > 
Creating Databases  

 Select BatchImportProperties.csv 
to map properties to the spectrum 
files using a spreadsheet 

 Make sure to check File Contains 
Header Line 

 Click Next 

The Spreadsheet File Import wizard opens:  
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Batch Import: many spectra, many records, import properties from a spreadsheet (continued) 

 Action Result 

4 Match  
 CSV file ‘id’ to SDBX/SDB file 

‘Record ID’;  

 CSV file ‘Synonyms’ to SDBX/SDB 
file “Synonyms”;  

 CSV file ‘Sadtler Reference’ to 
SDBX/SDB file ‘Sadtler Reference 
Number’.  

Alternatively, you can click Suggest 
All, then review the automatic field 
matches. 

Click Next. 

 
5 Click Finish.  

You do not have to Compact database 
now at the prompt. 

The database now has fields Synonyms and Sadtler Reference populated by the CSV file. 

 TIP You can rearrange the spreadsheet portion of this database (for example, to get rid of empty structure columns, 
right-click and choose Delete Columns). When edits are completed, you can save this column arrangement as a 
MineIt profile. Click Save Current Profile on the Profile toolbar, then type in a name for the new profile: 

 
This profile will be linked with this database. It can also be selected for use with other databases. 
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Batch Import: many spectra, many records, import properties from PubChem 

 Action Result 

1 Create a new empty database as in the 
above example. 

 

2  Choose File > Batch Import 

 Navigate to KnowItAll > Training 
Files > General Training > Files >  
PubChem > Raman  

 Select all spectral files in the folder  

 Click OK. 

 
A record is created in the new database for each spectral file.  
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3 Select the first record, then click the 
PubChem toolbar button.  

 

PubChem records are searched. If information is located, the PubChem Data Selection dialog box opens:  
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 Action Result 

4 Click OK.  New properties from PubChem are added to the first database record. 

5 Select the remaining database records 
by holding the Shift key, then choose 
Database > Batch PubChem 
Information Download.  

The Batch PubChem Information Download dialog box opens: 

 
6 Check the property fields you wish to 

add to the database records, then click 
Next.  

New properties from PubChem are added to the remaining database records.  
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Batch Import: many spectra, one record 

 Action Result 

1 Create a new empty database as in the 
above example. 

 

2  Choose File > Import 

 Navigate to KnowItAll > Training 
Files > General Training > Files > 
Creating Databases > Multiple 
Raman 

 Select all files in the folder  

 Click Open 

A dialog box opens and asks how you want to import the files: 

 
3 Click Import all files into this record. The Property Import Selection dialog opens: 

 
Check the properties you wish to import.  
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 Action Result 

4 Click OK each time the dialog appears.  The dialog box appears once for each spectrum in the record.  

5 With the first record selected, observe 
the Spectrum pane.  

The tab shows that there are 6 Raman spectra associated with the first record: 

 
6 Click the name of a spectrum in the left 

pane to display it. 
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 Action Result 

7 Choose Window > Split Threefold.  The Spectral pane is split into 3 panes, displaying 3 of the 6 spectra: 
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Training Files Used In This Lesson 
 benzylpenicillin.dsf 

KnowItAll Applications Used 
 MineIt™  
 ChemWindow®  

 

Creating Databases (optional section) 
How to Create a Database with Structures 

 
Purpose 
 
This exercise demonstrates how to use the KnowItAll’s MineIt™ Database Building feature to create searchable user databases that include structures.  
 

Objectives 
 
This exercise will teach you: 

 How to create a user database; 
 How to add structures to a user database; 
 How to display stereochemical properties; and 
 How to add user properties. 

 

Background 
 
Generating user databases protects intellectual property and promotes sharing of information 
within an organization. Ultimately, researchers can improve their analyses.  
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Create a user database 

 Action Result 

1 In the MineIt application, choose 
Database > New. 

The New Database Creation dialog box opens. 

 
3 Select Create on local system. The new database is saved locally. 

4  Click Browse 

 Navigate to the Databases folder 
you created earlier,  

 Type structures-sc in the 
Database File Name 

 Click Save. 

The *.sdbx extension is added automatically.  
Note: The SDBX database format allows spectra to be stored without conforming to a fixed range and resolution. 
This allows reference spectra to be offered at higher resolution, and allows users to store original spectra as 
produced. 

5 Type Structures in the Database 
Name text box. 
Note: The file name is used if no other 
name is specified.  
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Create a user database (continued) 

 Action Result 

6 Type ‘STRSC’ in the Database 
Abbreviation text box. 
Note: The abbreviation must be 3-7 
characters long. 

 

7 Click OK. The new database has been created to receive your data. The Database Abbreviation appears on the database 
tab. 

 
8 Choose View > Windows/Tables > 

Spectrum Pane to remove the spectral 
display from the layout. 

Note: This command (and others like it) 
toggle the display of different panes in 
the main window.   
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 Action Result 

9 Click the Add a New Profile toolbar 

button , type the name ‘Structures’ 
in the New Profile dialog box, then 
click OK.  
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Add a structure to the first database record 

 Action Result 

1  Choose File > Import 

 Navigate to KnowItAll > Training 
Files > General Training > Files > 
Creating Databases  

 Open the structure file 
Benzylpenicillin.dsf. 

The structure is displayed in the Structure/Properties pane: 

 
2 Open the View menu and check 

Stereochemistry if it is not already 
checked.  

Stereochemical descriptors are shown on the structure when Stereochemistry is enabled on the View menu. 

 



 

108658‐ REV20201102  Copyright ©2020 by John Wiley & Sons, Inc. All rights reserved. 

KnowItAll Training   Create Databases - 32 

Add properties to the first database record 

 Action Result 

1 Click Add in the Structure/Properties 
pane. 

The Property dialog box opens.  

2 Select the property Name, then type 
‘benzylpenicillin’ in the Value text box. 

 
3 Click OK.  The Property dialog box closes, and the added property Name appears in the Structure/Properties pane.  
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Add properties to the first database record (continued) 

 Action Result 

4 Repeat to add the property Synonyms 
with the value ‘Sample 8254.’  

 

5 Repeat to add the property Comments 
with the value ‘82nd Street Pharmacy, 
May 4. Retrieved in trace quantities.’ 
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Add a second database record 

 Action Result 

1 Navigate to the Basics toolbox, then 
open the ChemWindow application by 
clicking its icon.  
Note: Do not use the Transfer to bar in 
this case.  

 

2 Draw this structure: 

 

 

3 Use the Selection tool to select the 
structure, then choose Edit > Copy. 

 

4 Use the KnowItAll Back button to return 
to the MineIt application. 

 

5  With the second database entry 
selected, choose Edit > Paste.  
A message box asks “Would you like to 
append the new data as a new record?” 
Click OK.  

The structure is added to the second record: 

 
6 Add the property Name with the value 

‘E-1,3-dichloro-2-butene.’ 
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Add a third database record 

 Action Result 

1 With the second database record still 
selected, choose Edit > Copy 
Structure.  

 

2 Select the third database record and 
choose Edit > Paste.  
A message box asks “Would you like to 
append the new data as a new record?”  
Click OK.  

The structure and properties are added to the third database record.  

 
3 With the third database record selected, 

double click in the 
Structure/Properties pane to open the 
structure in ChemWindow. 
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 Action Result 

4 Edit the structure as shown, then click 
Return to MineIt Database and Save.  

 

The structure is added to the third database record.  

5 Edit the property Name to ‘Z-1,3-
dichloro-2-butene.’ 
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KnowItAll Software Training 

Functional Group Analysis 
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Training Files Used in This Lesson 
 Test Structure.dsf 

KnowItAll Applications Used 
 AnalyzeIt™  

 

Functional Group Analysis   
How to Use the Knowledgebases to Identify or Differentiate Classes of Compounds by Structure 
or Functional Group 

 
Purpose 
 
This exercise demonstrates how to use the AnalyzeIt™ IR, AnalyzeIt Raman, and AnalyzeIt Polymer IR Knowledgebases to identify or differentiate chemical 
compounds, and to correlate peaks by structure. 

 

Objectives 
 
This exercise will teach you: 

 How to specify the Knowledgebase; 
 How to browse by functional group; and 
 How to correlate a structure.   

 

Background 
 
The IR and Raman Knowledgebases include group frequencies with over 600 band assignments, 
corresponding to over 200 functional groups, subdivided into general chemical classes. 
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Specify the Knowledgebase 

 Action Result 

1 Navigate to the Spectral Analysis 
toolbox 
 
 
 
 
 
 
Click AnalyzeIt 

  

  
Open Spectrum - starts with any spectrum file.  Upon selecting an IR spectrum, KnowItAll asks user if it should 
be put into Organic IR or Polymer IR application. 

Open Structure - starts with any structure file.  Upon selecting a structure file, KnowItAll asks user if it should be 
put into Organic IR or Organic Raman application. 

By the same token, 

 IR Organic - starts a blank AnalyzeIt IR application 
 Polymer IR- starts a blank  AnalyzeIt Polymer IR application 
 Raman Organic - starts a blank AnalyzeIt Raman application 
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2 Let’s start from technique: Organic IR 
Click Organic IR and then choose File 
> Preferences. 

The Preferences dialog box opens:  

 
Setting the Tolerance range allows you to determine how precise the matches are between your spectrum peak 
and the database. You can also choose to display a wavenumber (x-axis position) marker with the cursor as it 
moves around the Spectrum pane. Finally, use the check boxes to select the knowledgebase you wish to use.  

3 Make sure AnalyzeIt IR 
Knowledgebase is selected 
Click OK  
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Browse by functional group 

 Action Result 

1 Choose Analyze > Browse a 
Functional Group. 

The Browse By Functional Group dialog box opens:  

 
2 Select Aldehydes and click OK.  The Aldehydes tab is added to the AnalyzeIt IR display: 

 
Each functional group in the aldehydes group is listed separately in the Functional Group Data pane at the lower 
left, and each entry includes classification, group, bond, range, intensity, mode, and notes.  
Colored bars in the Bar Chart pane at the lower right represent the peaks associated with each functional group 
class selected in the Functional Group Data pane. The bars are intensity coded; lighter color means greater 
intensity. Corresponding peaks appear in the Spectrum pane. 
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 Action Result 

3 Choose Analyze > Browse a 
Functional Group again. 

The Browse By Functional Group dialog box opens:  

 
4 Select both Alcohols and Anhydrides, 

then click OK.  

Note: Select the first class, then hold 
down the ctrl key and click to select a 
second class. 

The XREF1 tab is added to the AnalyzeIt IR display: 

 
The tab is labeled XREF1 because it is the first tab containing a combination of classes. 
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Correlate peaks from a structure 

 Action Result 

1  Choose File > Close to clear the 
previous example display 

 Click Open Structure button 

 Navigate to KnowItAll > Training 
Files > General Training > Files > 
Functional Group Analysis  

 Open Test Structure.dsf 

A dialog box prompts user to choose between IR or Raman 

 
2 Click Organic IR After the knowledge base is analyzed, the results are displayed in a Structure tab. The Functional Group Data 

pane includes an entry for each group found in the structure. 
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 Action Result 

3 Choose View > Sadtler Handbook to 
display the handbook information 
related to a particular functional group. 

The Sadtler Handbook pane displays information from the Sadtler Handbook of Reference Spectra - IR for the 
specific functional group selected in the Functional Group Data Pane.  
 

  
Double clicking the Sadtler Handbook pane's title bar allows you to dock and un-dock the pane with reference to 
the main display.  

4  Choose File > Close.  The display is cleared. 
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Training Files Used in This Lesson 
 Peak Interpretation Example.dx (IR) 

KnowItAll Applications Used 
 AnalyzeIt™  

 

Functional Group Analysis   
How to Perform a Basic Spectral Analysis Using Software-Assisted Functional Group Analysis 

 
Purpose 
 
This exercise demonstrates how to use the AnalyzeIt™ application to perform a basic spectral analysis. 

 

Objectives 
 
This exercise will teach you: 

 How to select peaks for correlation; and 
 How to use the Summary+ and Summary- tabs. 

 

Background 
 
The AnalyzeIt application can be used to help interpret spectra through the use of its knowledge 
bases of over 200 functional groups. They can be used to obtain functional group information from 
a spectrum or a structure, or by browsing the chemical classes included in the knowledge bases. 
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Open a spectrum 

 Action Result 

1 Navigate to the Spectral Analysis 
toolbox, and click AnalyzeIt followed by 
Organic IR. 

 

2  Right-click in the Spectral Pane. A pop-up menu opens: 

 
3  Click Open Spectrum 

 Navigate to KnowItAll > Training 
Files > General Training > Files > 
Functional Group Analysis  

 Open Peak Interpretation  
Example.dx.  

 Since this particular spectrum does 
not have the X-axis unit defined, 
KnowItAll warns the user with a 
pop-up saying The information 
stored as “Propyl alcohol” does 
not have X axis unit defined for 
the spectral trace. KnowItAll will 
attempt to read the data as cm-1. 

 Click OK. 

The spectrum is displayed: 
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Analyze the spectrum 

 Action Result 

1 Click the Suggest toolbar button .  
 

The application selects a peak to analyze: 

 
In general, it is best to begin a correlation with a peak above 1500 wavenumbers that is unique and strong. The 
AnalyzeIt application uses a set of rules to select a good starting point. 

2  Click the Suggest toolbar button again. 

Note: You can also select peaks by 
clicking in the spectral pane.  

Another peak is suggested: 

 
As you click the Suggest a Peak toolbar button repeatedly, the application cycles through the suggested starting 
points.  
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 Action Result 

3 Click Suggest until the second peak (at 
2964) is selected and then click the 

Correlate button . 

After the knowledge base is analyzed, the results are displayed in a tab labeled with the wavenumber.  
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 Action Result 

4  Select the alkanes entry C-(CH3)3 in 
the Functional Group Data pane 

 Right-click to open the Summary 
pop-up menu. 

Note: The Summary+ and Summary– 
tabs are created automatically, and are 
provided to allow you to keep track of 
functional groups that are consistent 
with or inconsistent with the measured 
spectrum. 

 
 

5 Because the methyl group correlates 
well with the spectrum, click Add to 
Summary+.  

The peaks are added to the Summary+ tab and the Summary Bar Chart pane (between the spectral display and 
the Bar Chart pane), and a summary plus symbol appears in the Functional Group Data pane next to this group. 
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 Action Result 

6 Select the first carboxylic acid entry (C-
C-COOH) in the Functional Group 
Data Pane, then right-click to open the 
Summary pop-up menu. 

 

7 Because the results indicate that there 
should also be a strong band near the 
1740 region, move this group to the 
Summary– tab. 

 
8 Click the Summary+ tab to display any 

groups added to this tab.  

 
9 Click the Summary- tab to display any 

groups added to this tab. 

 
10 Choose File > Close.  The display is cleared. 
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Training Files Used in This Lesson 
 Mixture of Polymers.irf  
 Polystyrene.irf  

KnowItAll Applications Used 
 AnalyzeIt™  

 

Functional Group Analysis   
How to Perform a Basic Spectral Analysis Using AnalyzeIt™ for Polymer 

 
Purpose 
 
This exercise demonstrates how to use the AnalyzeIt application to perform a basic spectral analysis of polymer 

 

Objectives 
 
This exercise will teach you: 

 How to analyze spectra from polymer samples.  
 

Background 
 
The AnalyzeIt Polymer IR Knowledge Base can provide clear and rapid verification and 
identification of functional groups in the mid-infrared. It features over 100 functional groups and 
hundreds of interpretation frequencies. 
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Open and analyze a mixture spectrum 

 Action Result 

1 Navigate to the Spectral Analysis 
toolbox, click on Open Spectrum  

 

2   Navigate to KnowItAll > Training 
Files > General Training > Files > 
Functional Group Analysis  

 Open Mixture of Polymers.irf.  

 Click on Polymer IR button in the 
pop-up dialog. 

Note: Use the Files of type filter to 
locate IRF, JCAMP, and many other 
specific spectral files. You can also 
select All files (*.*).  

The spectrum opens: 
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 Action Result 

3 Use the Suggest button to select the 
tallest peak (at 1188), then click the 

Correlate button .  
 
Alternatively, you can double-click a 
peak to both select it and initiate 
searching the knowledgebase(s) for 
functional group matches. 

After the knowledgebase is analyzed, the results are displayed in a tab labeled with the wavenumber (1188). 
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 Action Result 

4 Select each entry in the Functional 
Group Data pane in turn.  
Note that the first Polyether-Polymer IR 
entry (Poly (2,6-dimethyl-1,4-phenylene 
oxide)) is a good match.  

 
5 Right-click the entry, then select Add to 

Summary+. 
The entry is added to the Summary+ tab.  
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 Action Result 

6 Click the Suggest button to select the 
peak at 3028,       then click the 

Correlate button . 

After the knowledge base is analyzed, the results are displayed in a tab labeled with the wavenumber. 

 
Note the detailed notes available with many Functional Group entries.  
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Open and analyze a mixture spectrum (continued) 

 Action Result 

7 Select each entry in the Functional 
Group Data pane in turn.  
Note that the Aromatic Hydrocarbon 
(Polystyrene) entry is a good match. 

 
8 With the Aromatic Hydrocarbon 

(Polystyrene) entry selected, right-click 
then select Add to Summary+. 

The entry is added to the Summary+ tab.  
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 Action Result 

9 Open the Summary+ tab and select 
both entries. 

Note: Select the first entry, then hold 
down the ctrl key and click to select the 
second entry.  

We see that these functional groups account for most of the peaks in the mixture spectrum. 
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Open and analyze a single component spectrum 

 Action Result 

1 Close the previous analysis by clicking 
the close button in the upper right-hand 
corner. 

 

2   Choose File > Open Spectrum,  

 Navigate to KnowItAll > Training 
Files > General Training > Files > 
Functional Group Analysis  

 Open Polystyrene.irf. 

Note: Use the Files of type filter to 
locate IRF, JCAMP, and many other 
specific spectral files. You can also 
select All files (*.*). 

A pop-up dialog displays two options; 
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3 Click on Polymer IR. The spectrum opens: 
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 Action Result 

3 Click the Suggest button to select the 
peak at 2924.1, then click the Correlate 
button. 

After the knowledge base is analyzed, the results are displayed in a tab labeled with the wavenumber (2924.08). 
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 Action Result 

4 Select each entry in the Functional 
Group Data pane in turn. 

Note that Aromatic Hydrocarbon (Polystyrene) is a good fit: 

 
5 With the Aromatic Hydrocarbon 

(Polystyrene) entry selected, right-click, 
then select Add to Summary+. 

The functional group is added to the Summary+ tab. 



 

108658‐REV20201102  Copyright ©2020 by John Wiley & Sons, Inc. All rights reserved. 

KnowItAll Training  Functional Group Analysis - 26 

 

 Action Result 

6 Click the Suggest a Peak toolbar 
button again, then click the Correlate 
toolbar button.  

After the knowledge base is analyzed, the results are displayed in a tab labeled with the wavenumber (3024.38). 
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 Action Result 

7 Select each entry in the Functional 
Group Data pane in turn. 

Note that the Aromatic Hydrocarbon (Polystyrene) is, once again, a good fit: 
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 Action Result 

8 Repeat the process to analyze the third 
suggested peak (3080.3), then select 
each entry in the Functional Group 
Data pane in turn. 

Aromatic Hydrocarbon (Polystyrene) is a good fit: 
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Training Files Used in This Lesson 
 Test Structure.dsf 
 Butylamine.jdx 

KnowItAll Applications Used 
 AnalyzeIt™ 

 

Functional Group Analysis   
How to Create a User Knowledgebase 

 
Purpose 
 
This exercise demonstrates how to create and use user Knowledgebases in the AnalyzeIt™ applications. 

 

Objectives 
 
This exercise will teach you: 

 How to create a user Knowledgebase; 
 How to browse by functional group; and 
 How to correlate a structure.   

 

Background 
 
Users can build their own knowledgebases with functional groups and bands from their own data. 
The knowledgebases can be used in conjunction with KnowItAll’s knowledgebases to determine 
the functional groups in a spectrum. 
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Create a user knowledgebase 

 Action Result 

1 Navigate to the Spectral Analysis 
toolbox and open the AnalyzeIt 
application by clicking its icon. 

Click Organic IR button. 

 

2 Choose Knowledgebase > New.  A Save As dialog box opens.  

3 Type in a name for the user 
knowledgebase (such as User IR 
Knowledgebase) and save it to a 
location on your hard drive. 

 
The file type - Sadtler Knowledgebase, *.skbx or *.sbk – cannot be changed.  
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4 Right-click in the Functional Group 
Tree pane (on the left), then select Add 
Classification.  

The Classification dialog box opens:  

 
Type in AmineA and click OK.  
Note: Use a descriptive identifier to make sure the classification appears in the correct order when browsing for a 
functional group. Add a unique identifier to the end of the classification name to identify the knowledgebase where 
the entry appears. Changes can be made easily if necessary.  
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 Action Result 

5 Right-click on the new classification 
name AmineA, then select Add 
Functional Group.  

The Functional Group dialog box opens:  

 

6 Type R-CH2-NH2 in the upper text box.  The text is automatically formatted:  
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 Action Result 

7  Click Browse 

 Navigate to KnowItAll > Training 
Files > General Training > Files > 
Functional Group Analysis  

 Select Butylamine.jdx 

 The path and file name is displayed 
in the Reference Spectrum text 
box.  

  

8 Click OK to close the dialog box.  

Right-click on R-CH2-NH2 in the 
Functional Group Tree.  

A pop-up menu opens: 
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 Action Result 

9  Click Add Band.  

 Type in NH2, then add other 
information as follows:  

 Range from 1650 to 1590 
Height: 40 
Width at Half Height: 80 
Intensity: medium-strong 
Mode: deformation 

 Click OK. 

The Band dialog box opens:  

  
10    
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 Action Result 

11 Double-click in the Fragment 
Structure pane to open 
ChemWindow, then draw this 
structure: 

 

 

12 Click Save.  The structure is added to the display:  
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 Action Result 

13 Continue the process to add additional bands:  

Band Position Height Width at 
Half Height 

Intensity Mode 

NH 3400-3320 30 65 medium anti-symmetric stretching 

NH 3328-3250 30 65 medium symmetric stretching 

CN 1090-1068 40 40 medium-weak stretching 

NH 850-750 50 49 strong wagging 
 

Knowledgebase information is saved automatically.  

 
14 Click  in the upper right corner to close the knowledgebase.  
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Specify the user knowledgebase 

 Action Result 

1 Navigate to the Spectral Analysis 
toolbox and open the AnalyzeIt IR 
application by clicking its icon. 

 

2 Choose File > Preferences.  The Preferences dialog box opens.  

3 Click Add, then browse to and select 
the newly created user knowledgebase. 

The user knowledgebase is displayed in the Preferences dialog box:  

 
4 Click OK to close the Preferences 

dialog box.  
 

5 Choose Analyze > Browse a 
Functional Group.  

The contents of the user knowledgebase have been added to the list of functional groups: 
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KnowItAll Applications Used 

 ChemWindow®  
 

 
Optional: Drawing and Reactions   
How to Draw Chemical Structures 

 
Purpose 
 
The ChemWindow® application is a full-featured 2-dimensional structure drawing program. You can use the ChemWindow application to create chemical 
structures that can be used throughout the KnowItAll Informatics System for searching, prediction, and reporting chemical composition. 
 

Objectives 
 
This exercise will teach you: 

 How to use basic ChemWindow tools to create and edit a structure drawing; 
 How to save a structure for further use. 

 

Background 
 
Chemical structures can be used throughout the KnowItAll Informatics System for searching, 
prediction, and reporting chemical composition.  
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Begin a new structure drawing 

 Action Result 

1 Click the ChemWindow icon in the 
Basics toolbox. 

The ChemWindow application opens to a blank drawing pane. 

2 Select the Benzene Ring tool  in 
the Main section of the Chemistry 
Toolbar. 

 

3 Move the cursor into the drawing area, 
then click to draw a benzene ring. 

The benzene ring structure is placed in the drawing area:  

 
4 If desired, use tools on the zoom 

toolbar to change the magnification. 
Note: Choose View > Zoom Toolbar to 
toggle the toolbar display. 

 
 
The ctrl + scroll function can also be 
used to zoom in and out quickly. 
 

 

5 Use the Selection tool  to select the 
structure and move it within the 
workspace. 

Graphic handles appear when the structure is selected: 

 

 



 

108658‐REV20201102  Copyright ©2020 by John Wiley & Sons, Inc. All rights reserved. 

KnowItAll Training   Drawing and Reactions - 4 

Add features to the structure 

 Action Result 

1 Select the Cyclopentane tool , then 
move the cursor to the highlighted bond 
on the benzene ring. 

 
 

2 Click to join a cyclopentane ring to the 
benzene ring. 

 
3 Open the Bonds group in the Drawing 

Toolbar, select the Inside Double 

Bond tool , then use it to add a 
double bond to the structure. 

 
4 Select the Single Bond tool , then 

move the cursor over the atom’s hit box 
as shown. Click to create a single bond. 

 
Note: If you don’t release the cursor, you can control the bond direction by dragging. 

5 Continue adding single bonds by 
clicking on hit boxes on atoms. 
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Use hot keys to add nitrogen and oxygen atoms 

 Action Result 

1 Move the cursor over the terminal 
carbon, then press n on your keyboard. 

NH2 appears at the end of the bond: 

 
Note: Numbers are automatically displayed as subscripts when using hot keys, which are shortcut keys you can 
use to quickly label atoms. 
You can also use the atom label tool to add atoms to a drawing. However, unlike atoms added while using a bond 
tool, atoms in atom labels are not actually part of the structure, and will not be included when calculating the mass 
or chemical formula. 

2 Repeat to replace a carbon atom with 
NH. 

 
3 With the single bond tool still selected, 

place your cursor over the terminal 
carbon atom and click to add another 
single bond. 
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 Action Result 

4 Without moving the cursor, press o on 
your keyboard. 

 
5 Click to sprout another single bond, 

then press o on the keyboard to add a 
hydroxyl group.  

 
6 Press o again to remove the hydrogen. 

Note: When using a hot key, you can 
change the number of hydrogens 
attached to the atom by pressing the 
hot key repeatedly. 
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 Action Result 

7 Move the cursor to the hit box on the 
bond, then click to create a double 
bond. 
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Save the structure 

 Action Result 

1 Choose File > Save. 
Note: You can also click the Save 
button on the toolbar, or press Ctrl+S. 

The Save As dialog box opens. The default file type (ChemWindow structure file, *.dsf) is already selected, and 
will be used for this structure. Other file types include ChemWindow Structure Template & Style (*.dst) and MDL 
Mol file (*.mol). 

2 Navigate to the folder where you wish 
to save the structure file, then type in 
the file name “tryptophan.” 

 

3 Click Save. The structure is saved, and the file name is displayed on the drawing tab.   
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Edit the structure and use atom labels and atom tags 

 Action Result 

1 
Select the Eraser tool , then click 
to remove the hydroxyl… 

 
2 …and amino groups. 

 
3 Open the Main group on the Drawing 

Toolbar, select the Atom Label tool 

, then click where the hydroxyl 
group was located.  
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 Action Result 

4 Type uppercase O.   
Note: Atom labels are case-sensitive. 

 
5 Move to the other atom and type 

uppercase NH3. 
Note: Numbers are automatically 
displayed as subscripts if the Text 

Style toolbar’s Formula tool  is 
selected. 

 
6 Select the Positive Charge Atom Tag 

tool  to add a positive charge to the 
atom. 

 
 TIP Clicking and dragging a charge allows you more control over the placement of the charge. You can also use the 

Lasso tool to move the charge. 
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 Action Result 

7 Repeat with the Negative Charge 

Atom Tag tool  to add a negative 
charge to the oxygen atom.  

 
8 Choose File > Save As to save the 

structure with file name 
tryptophan2.dsf. 

 

 



 

108658‐REV20201102  Copyright ©2020 by John Wiley & Sons, Inc. All rights reserved. 

KnowItAll Training   Drawing and Reactions - 12 

Use pre-defined substituents 

 Action Result 

1 Click on the Label tool 

 
2 Select an atom and click to type 

Ala (a pre-defined substituent) 

>>>  
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 Action Result 

3 Click Chemistry > Make Stick 
Structure 

 
4  

 
The above is the expanded structure 
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Use Hotkeys 

 Action Result 

1  In the Main toolbox, select the 
Standard bond tool. 

 Click the structure pane to insert 
the single bond. The end of the 
bond will be highlighted 
automatically. 

 
2 Type the following characters on 

your keyboard: 9, 1, 3, 9, O 
(Capital O) 
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 Action Result 

3 Click Chemistry > Make Stick 
Structure 

 
The above is the expanded structure 
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Training Files Used in This Lesson 
 Structure 1.dsf 
 Structure 2.dsf 

KnowItAll Applications Used 
 ChemWindow® 
 ReportIt™ 

 

Drawing and Reactions   
How to Draw Chemical Reactions 

 
Purpose 
 
The ReportIt™ application is a full-featured chemical publishing program. Use the ReportIt application to import objects such as structures and spectra, arrange 
them on the page, and add text, annotations, reaction arrows, polygons, or orbitals.  

The ease with which information can be passed from one KnowItAll Informatics System application to another is especially evident in the way the ReportIt and 
ChemWindow® applications work together. Use ChemWindow to create structures and transfer them to ReportIt for incorporation in a report. Transfer structures 
from ReportIt to ChemWindow for editing.  
 

Objectives 
 
This exercise will teach you: 

 How to transfer objects between the ChemWindow and ReportIt applications; 
 How to use ReportIt tools to create a report that includes chemical reactions. 

 

Background 
 
Scientists can use the KnowItAll ChemWindow and ReportIt applications to add reaction schemes 
to reports. This capability is useful to anyone communicating the results of laboratory procedures. 
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Open a structure in the ChemWindow application 

 Action Result 

1 Click the ChemWindow icon in the 
Basics toolbox. 

The ChemWindow application opens to a blank drawing. 

2  Navigate to File > Open, then 
navigate to KnowItAll > Training 
Files > General Training > Files > 
Drawing and Reactions 

 Select Structure 1.dsf.  

 Click Open 

The file opens in the workspace: 

 
3 Click ReportIt in the Transfer to bar.  The structure opens in the ReportIt application. It is already selected and can be moved, re-sized, etc.  
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Set up the report 

 Action Result 

1 Click the Fit to Page Width tool  on 
the Zoom toolbar. 

The display adjusts so the entire page width is visible.  

2 Move the image so it is about 1” in from 
the left edge, and about 2” below the 
top of the page. 

Note: Choose View > Rulers to display 
rulers in the drawing area.  

Choose File > Preferences and select 
the Templates/Units tab to specify 
default measurement units on the 
drawing area rulers. 
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Use Text tools 

 Action Result 

1 Select the Text tool  on the Drawing 
toolbar’s Main group, then click and 
drag at the top of the page to create a 
text box.  

When you release the mouse button, the text box is bounded by hit boxes and the cursor is inside, ready for 
typing. Text tools become available.  

 
2 If necessary, display the Text Style 

toolbar (View menu), then adjust the 
font size to 24.  

 

3 Type Calcitrol Analogs Synthesis 
then click the Center Alignment tool 

 to center the text in the text box.  
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Create reaction arrows, and add a second structure 

 Action Result 

1 Select the Reaction Arrow tool  in 
the Drawing toolbar’s Main group, then 
click and drag to draw an arrow to the 
right of the structure. 

When you release the mouse button, the arrow is selected and ready to be moved or re-sized: 

 
Once the arrow has been drawn, you can resize it, reposition it, and change the direction and style of the 
arrowhead, if desired. Refer to ChemWindow online help or the KnowItAll User Guide for more information.  

2 Draw a text box above the arrow and 
type in the text shown at right. Repeat 
below the arrow.  

Note: You can type in the degree 
symbol by opening the Windows 
Character map (Start Menu > 
Programs > Accessories > System 
Tools in Windows 10), selecting and 
copying the symbol, then pasting it in 
the text box. 

 

3  Use the KnowItAll Back button to 
return to the ChemWindow 
application  

 Navigate to File > Open, then 
navigate to KnowItAll > Training 
Files > General Training > Files > 
Drawing and Reactions 

 Open Structure 2.dsf.   

4 Click ReportIt in the Transfer to bar. The drawing is copied into the ReportIt document.  

5 Use the Selection tool to move the 
newly-copied structure to the right of 
the reaction arrow.  

 

6 Draw another reaction arrow pointing 
downwards from the newly-copied 
structure. 
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 Action Result 

7 Add a text box to the left of the arrow 
and type in the text shown at right.  

 
8 

Click the Right Align tool … 
 

9 …then select ‘4’ in NaBH4 and click the 

Subscript tool .  
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Use ReportIt tools to create a third structure 

 Action Result 

1 Click the Selection tool, then select the 
second structure, copy it, and paste the 
copy below the reaction arrow. 
Note: There are many ways to access 
the copy and paste commands. Right-
clicking is one of the easiest. 

 

2 Double click the newly-pasted structure.  The Structure toolbar appears at the right edge of the drawing area. 

 
The Structure toolbar can be moved anywhere on the desktop, but remains only as long as the structure is 
selected. 

3 Use the Structure toolbar’s drawing 
tools to edit the structure. 
Note: Use the Atom Label and 
Hashed Wedge Bond tools to make 
the changes.   

change  to     
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 Action Result 

4 Click outside the structure to close the 
Structure toolbar, then click the Fit to 
Page button  to view the entire 
page. 

 
5 Choose File > Save.  
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Training Files Used in This Lesson 
 Wiley.GIF 
 Landscape.rtt 

KnowItAll Applications Used 
 ReportIt™ 
 MineIt™ 

 

Create Reports   
How to Create Customized Report Templates 

 
Purpose 
 
KnowItAll users can use report templates to easily generate high-quality documents including structures, spectra, tables, clip art, and more. Reports can be 
exported using a variety of formats, making it easier to share results with others.   
 

Objectives 
 
This exercise will teach you: 

 How to open and use pre-defined KnowItAll report templates; 
 How to create and use customized report templates. 

 

Background 
 
In addition to serving as the basis for reports, templates are used when objects and information are 
transferred to the ReportIt application from other KnowItAll applications. A template must be 
selected before any transfer can occur. A default template can be selected for each application, or 
a template can be chosen every time information is transferred to the ReportIt application. 
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Examine predefined KnowItAll templates 

 Action Result 

1 Open Windows Explorer, then navigate 
to Documents > Wiley > KnowItAll > 
Report Templates (Windows 10) 

Note: If you cannot find it in your 
version of Windows, use the Explorer 
search to locate it. 

Each KnowItAll application has its own report templates folder: 
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 Action Result 

2 Open the MineIt folder. The MineIt report templates are displayed:  

 
3 Close Windows Explorer.  
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Open a predefined template in the ReportIt and MineIt applications 

 Action Result 

1 Navigate to the Basics toolbox, open 
the ReportIt application by clicking its 
icon, then choose File > Open. 

  
An Open dialog box appears.  

2  Set the Files of type filter to 
ReportIt Template Document Files 
(*.rtt),  

 Navigate to KnowItAll > Report 
Templates > MineIt  

 Open Spectrum Landscape.rtt in 
the folder we examined earlier. 

The template opens: 

 
 



 

108658‐ REV20201102  Copyright ©2020 by John Wiley & Sons, Inc. All rights reserved. 

KnowItAll Training   Create Reports - 6 

 

 Action Result 

3  Navigate to the Data toolbox 

 Open the MineIt application by 
clicking its icon 

 Choose File > Edit Report 
Templates  

 Select the Landscape template.  

 

The Report Templates dialog box opens. 

 
4 Click Edit. The Objects to Add to Or Delete from Existing Template dialog box opens.  

 
Use this dialog box to see which objects are included with the template. You can also use this dialog to add or 
remove objects. 

5 Click Cancel; then click Close on the 
Report Templates dialog box. 

No changes were made to the template. 
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Create a new MineIt template 

 Action Result 

1 The easiest method to create a new 
Mineit template is to start with an 
existing template. 
 
With the MineIt application open, 
choose File > Edit Report Templates; 
then click New on the Report 
Templates dialog box. 

The Objects to Include dialog box opens: 

 
2 Move Spectrum Pane (WYSIWYG) 

from the list of Available Objects to the 
list of Included Objects by selecting it 
in the list on the left and clicking the 
right arrow available between the two 
lists. 

 

3 Move Database/Hit List Table from the 
list of Available Objects to the list of 
Included Objects. 
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4 With Database/Hit List Table selected 
in the list of Included Objects, uncheck 
Selected Only, then type 1 in the From 
box and 10 in the Count box. 

The first ten hits will be included on the template. 

 
5 Move Database/Hit List Spectrum 

(auto-detect type) from the list of 
Available Objects to the list of 
Included Objects, uncheck Repeat 
object… and Selected Only; then type 
1 in the Count box. 

The structure will be included only for the first item in the hit list. 

6 Move Property Table from the list of 
Available Objects to the list of 
Included Objects, uncheck Repeat 
object… and Selected Only; then type 
1 in the Count box. 

The property table will be included only for the first item in the hit list. 

7 Move Current Date/Time from the list 
of Available Objects to the list of 
Included Objects. 

A date/time field is added to the template.  
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8 Click OK.  The new template opens in the ReportIt application. 

 
We see object placeholders corresponding to the choices we made on the Objects to Include dialog box. You 
may have to scroll down the report template to see them all. We can now use ReportIt tools to arrange the 
placeholders and add other objects, such as images and text boxes. 



 

108658‐ REV20201102  Copyright ©2020 by John Wiley & Sons, Inc. All rights reserved. 

KnowItAll Training   Create Reports - 10 

Edit the template in ReportIt 

 Action Result 

1 Choose File > Document Size. The Document Size dialog box opens: 

 
2 Change Horizontal size to 2 and 

Vertical size to 1; then click OK.  
A message box appears to tell you that some objects may no longer be completely visible.  
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3 Click Yes. 
Move the database structure and 
property table to the second page, and 
re-size them as desired. 

 
  4  Navigate to KnowItAll > Training 

Files > General Training > Files > 
Creating Reports 

 Open Wiley.gif using any image 
editor (example MS Paint) 

 Select and copy the image.  
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5 Return to the ReportIt application and 
choose Edit > Paste. 

The image is added to the template: 
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 Action Result 

6 
Using the Text box tool , draw a 
text box, then type ‘Operator:’.  

7 Choose the Selection tool, then hold 
down the shift key and select both the 
Date/Time field and the text box. 

 

8 Choose Arrange > Group.  The two objects can now be moved, re-sized, etc., in exactly the same way.  

9 Double click within the WYSIWYG 
Spectrum Page. 

A spectrum toolbar opens. These tools can be used to adjust the spectral display in the template.  

10 On the Transfer to bar, click MineIt 
Database and Save.   

A Save As dialog box opens.  

11 Type in the new template’s name 
(WILEY) and click Save.  

The dialog box closes, revealing that the new template has been added to MineIt’s Report Templates dialog box.   

12 Select the new template and click Set 
as Default, then click Close.  

Because we have set the new template as the default template, it will be used automatically whenever information 
is transferred from MineIt to ReportIt. Setting a default template is useful when you want to use a single template 
most of the time. However, you can also choose not to have a default template, and select from the list of available 
templates each time you transfer information to ReportIt. 
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Training Files Used in This Lesson 

 Hexane.jdx  

KnowItAll Applications Used 
 MineIt™ 

 

Data Mining & Analysis   
Overlap Density Heatmap Technology: A New Technology to Analyze Spectral, Chromatographic, 
and Other Graphical Data 

 
Purpose 
 
This exercise demonstrates how to use Overlap Density Heatmap technology for data mining and visualization. 
 

Objectives 
 
This exercise will teach you: 

 How to view and manipulate an Overlap Density Heatmap. 
 

Background 
 
Wiley’s patented Overlap Density Heatmap technology is useful for visual data mining and analysis 
to assess the similarities and dissimilarities in large amounts of spectral, chromatographic, and 
other graphical data. 

This technology allows the visualization of common features of overlapped objects, such as spectra 
or chromatograms, by color-coding the areas from highest to lowest overlap. 
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Open a spectral hit list in the MineIt application 

 Action Result 

1 In the SearchIt application, click User-
Select under Search Databases.  

If databases are present in the 
Selected for Searching pane, click 
Remove All.  

Add the IR – Sadtler Standards 
(Selected Subset) – Wiley (DB Code 
SLX) to the Selected for Searching 
pane.  

 

2 Click Spectrum in the Search 
Categories pane 

Navigate to KnowItAll > Training Files 
> General Training > Files > Data 
Mining  

Open Hexane.jdx.   
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 Action Result 

3 Click Search. The results are displayed in the MineIt application: 
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 Action Result 

4 Select the first 15 entries in the hit list. 

Note: Select the first record, hold down 
the shift key, then scroll to and select 
the 15th entry.  

All the selected hits are displayed in the spectral pane.  

 



 

108658‐REV20201102  Copyright ©2020 by John Wiley & Sons, Inc. All rights reserved.  

KnowItAll Training  Data Mining & Analysis - 6 

Change the spectral display to Overlap Density Heatmap 

 Action Result 

1 Click the Overlap Density (OD) 
Heatmap tool  in the Spectral 
toolbar. 

The spectral display changes, and the Overlap Density (OD) Toolbar is added to the display. 

 
The default Overlap Density Heatmap display shows all overlap levels. High levels of overlap are displayed in red; 
low levels are displayed in violet. The OD Toolbar allows you to control the amount of overlap displayed using the 
slider. In the default Overlap Density Heatmap, the slider is set at OD level = 0, where all colors – representing all 
overlap density levels – are shown. 
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Manipulate the Overlap Density Heatmap 

 Action Result 

1 Move the slider on the OD Toolbar to 
the right.  

As the slider moves to the right, the areas of common overlap are shown. Only the areas of most common overlap 
are shown as the OD Level approaches 100.  
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 Action Result 

2 Move the slider to the left. As the OD Level approaches -100, only the areas of lowest overlap – the unique areas – are shown.  

 
As you move the slider to change the OD Level, a second value is shown in parentheses. This value is the percent 
area under the curve, or %AUC, relative to the value at OD Level = 0. In this case, %AUC = 40%. We can use the 
OD Level and %AUC to quantify the OD Heatmap. 
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 Action Result 

3 Move the slider to the point where 
%AUC equals approximately 50%. 

The OD Level on the common side – or ODC – required to show 50% of the area that is most in common, is 42. 

 
 
Another way to express this is to say that ODC50 = 42. An alternative is to say that %AUC42 = 50.   
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 Action Result 

4 Next, move the slider to the left to 
where %AUC equals approximately 
50%. 

The OD Level on the unique side – or ODU – required to show 50% of the area that is most unique is -57. 

  
Another way to express this is to say that ODU50 = -64. An alternative is to say that %AUC-64 = 50.   

 TIP 
Use the Horizontal Zoom tool  to examine different regions. To do this, select the Horizontal Zoom tool, and 

then click and drag over an area on the spectrum to zoom in. Use the View Entire Spectrum tool  to zoom 
out.  
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Training Files Used in This Lesson 
 Propiophenone Query.dsf 

KnowItAll Applications Used 
 SearchIt™ 
 MineIt™ 

Data Mining & Analysis   
How to Create and use Overlap Density Consensus Spectra 

 
Purpose 
 
This exercise demonstrates how to create and use Overlap Density Consensus Spectra in the KnowItAll Informatics System. 
 

Objectives 
 
This exercise will teach you: 

 How to view and manipulate an Overlap Density Consensus spectrum; 
 How to use an Overlap Density Consensus spectrum in a search.  

 

Background 
 
Wiley’s patented Overlap Density Heatmap technology is useful for visual data mining and analysis 
to assess the similarities and dissimilarities in large amounts of spectral, chromatographic, and 
other graphical data. 

By tracing the outline of the highest level of overlap at a given OD Level, it is possible to 
mathematically construct a composite spectrum by using the maximum spectral y-values at each 
spectral x-value in the OD Heatmap. This Overlap Density Consensus Spectrum can be used in a 
spectral search to find similar spectra, or can be stored in a database for future use. 
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Perform a substructure search 

 Action Result 

1  In the SearchIt application, click 
User-select under Search 
Databases.  

 Under Available for Searching, 
select IR – Sadtler Standards 
(Selected Subset) – Wiley (DB 
Code SLX)  

 Click Add 

 

2  Click Structure button  
 Click Open Spectrum or Structure 

icon 
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 Action Result 

3 Navigate to KnowItAll > Training Files 
> General Training > Files > Data 
Mining 
Open Propiophenone Query.dsf.  

The structure is displayed in the Structure tab.  

 
4 Make sure Search Mode is set to 

Substructure. 

Click Search. 

Results are displayed in the MineIt application.  
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Examine the results in MineIt 

 Action Result 

1 Select all eleven records in the hit list. 
Note: Select the first record, hold down 
the shift key, then scroll to and select 
the last record. 

All spectra are displayed in the spectral pane: 

 
2 Click the OD Heatmap toolbar button…  
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 Action Result 

3 …then click the OD Consensus 

Spectrum toolbar button .  

The consensus spectrum is displayed above the Overlap Density Heatmap: 
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 Action Result 

4 Click the OD Heatmap toolbar button 
again to turn off this display. 

The consensus spectrum remains in the display. 
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Use the consensus spectrum to perform a search 

 Action Result 

1 Click SearchIt in the Transfer to bar.  The consensus spectrum is displayed on the IR Spectrum search tab. 

 
2 Click the Search button. 

Note: The IR – Sadtler Standards 
(Selected Subset) – Wiley database 
remains in the spectrum pane.  

The results are displayed in the MineIt application on a new tab: 
As you can see from this example, the Overlap Density Consensus Spectrum created from a hit list of spectra 
containing the propiophenone substructure produces a spectrum that is very similar to propiophenone itself.  
The use of Overlap Density Consensus Spectra, therefore, has clear applicability in structure elucidation and 
unknown identification.  
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KnowItAll Informatics Training 

Quality Control Analysis with QC Expert 
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Training Files Used in This Lesson 
 DEET.SPA 
 Epichlorohydrin Sample Spectrum.irf 

KnowItAll Applications Used 
 QC Expert 

QC Expert 
Perform a Quality Control Comparison of a Sample Spectrum Against a Reference Spectrum 
 

Objectives 
 
This exercise will teach you: 

 How to set up an account 
 How to select a standard 
 How to compare to a selected standard 
 How to generate a report 

 

Background 
 
Wiley’s KnowItAll QC Expert software performs a rapid quality check of a sample IR or 
Raman spectrum against a “gold standard” user spectrum to verify that a material meets 
control specifications.  

 



  

108658‐REV20201102  Copyright ©2020 by John Wiley & Sons, Inc. All rights reserved.                                                                                      

KnowItAll Training   QC Expert - 3 

Set Up Administrator Account and Address 

 Action Result 

1 Navigate to the Data toolbox and open 
the QC Expert application. 

 

2 To create an administrative account, go 
to File > Digital Signature 
Administration…  
 

 

3  Enter your preferred user ID in the 
Digital Signature field 

 Enter preferred password in the 
Password and Confirm Password 
fields 

 Click OK 

 

4 In the Administrator Verification pop-
up that appears, enter your user name 
and password. 
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5 In File > Settings, set the Organization 
to “Wiley Laboratories, Inc.” and add 
address. 
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Select Reference Database 

 Action Result 

1  In the Reference/Validation 
Databases tab, click the Select by 
Browsing button  

 Navigate to KnowItAll > Training 
Files > General Training > 
Databases > Samples folder  

 Select the Multi-Technique Sadtler 
Demo Database - Wiley [DEMO] 
database.  

 

2 Click OK.  



 

108658‐ REV20201102  Copyright ©2020 by John Wiley & Sons, Inc. All rights reserved. 

KnowItAll Training   QC Expert - 6 

3 Click on the Select Reference button 
at the lower right of the QC Expert 
window. 

 

4  At the prompt, login as 
administrator. The Add Reference 
Spectrum dialog box opens. 

 Type deet in the Filter box to 
search for DEET. 

 Point out the Comparison 
Algorithm, Match Threshold, and 
Proximity Warning parameters in 
the lower left.  

 Select the Correlation (Classic) 
algorithm for the demo. 

 Click OK to add the spectrum. 
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5  The Reference Spectrum 
Selection dialog box opens.  

 Click on Add, and type epi in the 
Filter box.  

 Select R-(-)-Epichlorohydrin and 
select the Correlation (classic) 
algorithm. 

 Click OK. 

 



 

108658‐ REV20201102  Copyright ©2020 by John Wiley & Sons, Inc. All rights reserved. 

KnowItAll Training   QC Expert - 8 

Run QC Expert as a Non-administrator QC Analyst 

 Action Result 

1  Navigate to the Data toolbox and 
open the QC Expert application. 

 Click on the Select Reference 
button. Select the DEET spectrum 

 Click OK. 

 

2  Click on New Comparison at the 
mid-left of the QC Expert window. 

 Navigate to KnowItAll > Samples > 
QC Expert folder and select 
DEET.SPA. 

 Set Imported spectrum is to ATR-
IR and ensure this option is 
checked.  

 Click Open. 
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3  The QC Expert window displays the Comparison Status.  

 
We get an excellent match of 99.1% and a green check mark indicating that the quality control comparison passes. 

4 Mouse over the green and red bars in 
the Match % of All Reference Spectra 
chart. 

Note: When you mouse over the 
various bars in the Match% Chart, you 
see the corresponding display in the 
Spectrum Pane at the top. 

 
The Match % of All Reference Spectra chart shows the comparison of the sample spectrum to spectra from the 
entire reference database. The green bars are for the comparison of the sample spectrum against the selected 
reference spectrum as well as all other reference spectra for different lots of the same compound. The blue line is 
the quality control threshold, and the red lines are the match % values for the comparison of the sample spectrum 
against all the other spectra in the database. 
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5 Double-click on the PDF 
attachment in the Attachment 
pane at the lower right.  

The DEET safety datasheet and other associated information is displayed. 
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 Demo Protocol - QC Analyst Comparison of R-(-)-Epichlorohydrin Sample Spectrum to Reference 

 Action Result 

1  Navigate to the Data toolbox and 
open the QC Expert application. 

 Click on the Select Reference 
button.  

 Select the R-(-)-Epichlorohydrin 
reference spectrum. 

 Click OK. 

This is to open a spectrum of a sample of R-(-)-Epichlorohydrin and perform a quality control comparison to 
make sure that the sample actually is what it is supposed to be. 

2  Click on New Comparison at the 
mid-left of the QC Expert window. 

 Navigate to KnowItAll > Samples >   
QC Expert folder. 

 Select Epichlorohydrin Sample 
Spectrum.irf. 

 Set Imported spectrum is to ATR-
IR and ensure this option is 
checked.  

 Click Open. 

 
The Match% between the selected reference spectrum and sample spectrum is excellent at 99.1%, but the QC 
comparison is Uncertain. 
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3 Click on the information button 🛈. 

 

 

 
An ID Expert pop-up says that the sample spectrum meets the match threshold, but there are other spectra that 
match even better or are within the proximity warning.   

4 Click OK to close the dialog box.  

5 On the Match% chart, mouse over the 
bars near 100% and look at the 
corresponding spectra in the spectrum 
pane above.  

There are two lines above the blue threshold line indicating two hits, one in green and one in yellow. 

6 Mouse over the green bar in the Match 
% Chart. The hover-over text says R-(-
)-Epichlorohydrin: 99.1%. 

 
The green bar in the Match % chart indicates the comparison of the sample spectrum to the reference spectrum.  
The match percent is 99.1% 

7 Mouse over the yellow bar in the Match 
% Chart. The hover-over text says S-
(+)- Epichlorohydrin: 99.7%. 

 
The yellow bar is for S-(+)- Epichlorohydrin, which is the enantiomer of the R-(-) isomer. The R and S forms of 
Epichlorohydrin are stereoisomers that are indistinguishable by IR. 
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8 Click on Create Report button below 
the Match% chart to create a digitally 
signed report.  

 Select your user name from the 
Digital Signatures drop-down. 

 Enter the password 

 Fill out the sample information.. 

 
9 Click OK to view the report. The digitally signed PDF contains the following information: 

Page 1 – Information about the test 
Page 2 – Information about the spectral comparison 
Page 3 – Information about the reference spectrum 
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